0

I have a lan of about 10-15 clients (depends on counting tablets and so on..). To access them from one station I use tightvnc which works like a charm - up to now. Sometimes I cannot access and I don't know why. When I access manually and so on, then it works, out of the blue. Are there some commonly known "features" I don't know?

closed as too broad by Rui F Ribeiro, Thomas Dickey, Jeff Schaller, msp9011, Totor Sep 5 '18 at 6:23

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I don't understand how this is too broad. I immediately recognized what his problem might be based on his title. – ron Sep 5 '18 at 19:25
1

VNC works on ports 5900 and up; 5900 for the service I believe then 5900+n for each n user desktops.

so if you are the 7th user for example and you get desktop :7, you would need port 5907 in addition to 5900 being opened in your firewall.

depending on your linux distribution, they sometimes manage only a few ports upward or 5900, your 10-15 clients is likely exceeding that and your firewall may be blocking VNC for those desktops.

a not uncommon but not necessarily correct practice is to just open ports 5900:5999 in your firewall, which would account for up to 99 users... or disable firewall if that is acceptable on your LAN

  • Interesting, thanks a lot! I will apply this. To add something I should have done before: When I restart the computer, then it works from the beginning on. Hence, my feeling is that it appears when the computer is idle and not used for a while (say >15min). Could this be possible somehow? – Ben Sep 5 '18 at 9:47
  • 1
    rebooting will clear the VNC connections list, starting in the basement at 5900 again and would work, as more and more user's connect going to ports 5900+n is when the firewall would start blocking. – ron Sep 5 '18 at 19:16
  • I use SUSE, and by default they open ports 5900:5904 where 5901 is a non-persistent VNC remote desktop with resolution of 800x600; 5902 is :2 at 1024x768 res; and 5903 is :3 at 1600x1200 res. Therefore as users do vncserver to get a persistent remote connection for themself things are fine for the first three users, user #4 and higher would get blocked by firewall and vnc would not work for them with no error message given. – ron Sep 5 '18 at 19:19
  • as such anyone getting desktop :1, :2, or :3 is fine. When it goes to :4 and above at port 5904 and above would be blocked by firewall, unless the firewall is customized. this is something that may be different for every linux distribution: rhel, sles, debian and so on. – ron Sep 5 '18 at 19:29
  • Thanks a lot again! This information is very helpful to understand the ongoing processes. I just noticed that this SE site is dedicated for unix/linux but I'm using tightvnc on windows because I have to due to business requirements. Personally I prefer linux too :) – Ben Sep 11 '18 at 6:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.