3

I'm trying to play videos I recorded from my mobile phone (the stock video / photo app on a Samsung Galaxy On7).

When I click them I get the following error message from Totem on Fedora 28:

H.264 (High Profile) decoder is required to play the file, but is not installed

H.264 (High Profile) decoder is required to play the file, but is not installed

Clicking "Find in programs" doesn't find an appropriate codec.


The file tool labels them as "ISO Media, MP4 v2 [ISO 14496-14]".


This is the error log when I run Totem from the CLI:

** Message: 12:57:35.979: Missing plugin: gstreamer|1.0|totem|H.264 (High Profile) decoder|decoder-video/x-h264, level=(string)4, profile=(string)high, interlace-mode=(string)progressive, chroma-format=(string)4:2:0, bit-depth-luma=(uint)8, bit-depth-chroma=(uint)8 (H.264 (High Profile) decoder)

6
sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
sudo dnf install gstreamer1-libav

(source)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.