2

I got stuck while trying to update two specific packages (e.g. "samba-common" and "openssh-server", for completion's sake), throwing the following error on the terminal:

subprocess installed post-installation script returned error exit status 139

After searching the web, all I found out was that somewhere, someway, something was exiting due to a SIGSEGV signal, and that I could debug the post-install script by heading on over to '/var/lib/dpkg/info/'.

After some echo debugging, I was able to narrow down the offending command to:

ucf --three-way --debconf-ok /var/run/samba/upgrades/smb.conf /etc/samba/smb.conf

The command runs does not output any error messages, including "Segmentation Fault", but its exit code is indeed '139'.

I've since tried running apt-get install --reinstall ucf, but the result is the same.

How can I further debug this? Any logging I can check to see if a particular dependency of UCF is causing this?

  • Ok, just tried to lookup the manpage for ucf, only to find "tbl: Segmentation fault"; related? I also had trouble with locales, recently, and ended up fiddling around with localegen. – ravemir Sep 3 '18 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.