3

On my Arch Linux the touchpad stopped working (I assume after an update). After reinstalling Arch it still doesn't work.

I checked the following things:

  • The touchpad is not disabled in the BIOS, since it works when I install Ubuntu (or use an Ubuntu live USB)
  • xf86-input-synaptics is installed. The last time this was automatically installed but even after manually installing the touchpad does not work
  • I also copied the files from /usr/share/X11/xorg.conf.d/ to /etc/X11/xorg.conf.d/ as some sources say this can be needed for the touchpad to work
  • The xorg meta package is installed and I use i3wm. So there is no switch to wayland or something that broke it.

When I use xinput list I get the following output. The touchpad is not listed.

⎡ Virtual core pointer                      id=2     [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer            id=4     [slave  pointer  (2)]
⎜   ↳ USB Optical Mouse                     id=12    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3     [master keyboard (2)]
     ↳ Virtual core XTEST keyboard          id=5     [slave  keyboard (3)]
     ↳ Power Button                         id=6     [slave  keyboard (3)]
     ↳ Video Bus                            id=7     [slave  keyboard (3)]
     ↳ Sleep Button                         id=8     [slave  keyboard (3)]
     ↳ Integrated Camera: Integrated C      id=9     [slave  keyboard (3)]
     ↳ AT Translated Set 2 keyboard         id=10    [slave  keyboard (3)]
     ↳ ThinkPad Extra Buttons               id=11    [slave  keyboard (3)]
2
  • have you solved this issue?
    – LazyCat01
    Jan 5, 2020 at 18:17
  • My problem was gone after shutting down computer, waiting for a minute and turning it on again. Strange glitch.
    – LazyCat01
    Jan 5, 2020 at 23:20

2 Answers 2

1

Your guess is right! its probably because of changing your system from Xorg Server to Walyland! Please check that if you are using Xorg or Wayland! Also if you are using wayland, change it to Xorg on gdm and tell me if your problem solved or not, so I can update my answer with more details...

In the case it don't work properly even with changes on windows manager, please consider this wiki page for more proper solutions: https://wiki.archlinux.org/index.php/Libinput

1
  • I am pretty sure I didn't switch to wayland. Unless the xorg group would install wayland. Also I use i3 which doesn't work on wayland afaik. Sep 4, 2018 at 6:18
0

Certainly not a solution to the problem, but solved by problem then I think it is worth sharing.

I have Arch Linux installed on a Lenovo Legion 5i. Many of the function keys simply didnt work (volume +/-, brighness +/- etc) then I was mapping them to my window manager (i use QTile) and making them work.

Happens that toggle touchpad (fn + F10) was one that worked without any config in qtile. I didnt know what the symbol meant, I clicked it to see in xev what it was mapped like, and by doing that I disabled touchpad. I was using mouse at the moment, then simply didnt notice it. When I had to use touchpad it didn't work, and I lost some time until I figure that out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.