0

Tried to install AMD Radeon HD 7870 Ghz graphics drivers and now Linux Mint doesnt want to boot.

I installed the generic "Linux x86_64" driver from this

https://www.amd.com/en/support/graphics/amd-radeon-hd/amd-radeon-hd-7000-series/amd-radeon-hd-7870-ghz-edition

page and installed it via the AMD Catalyst Proprietary Driver Setup, and got an error message popping up in a separate window saying something along the lines "there was an error during installation, the log file was saved in some directory" however the main driver setup window said installation was successful and reboot was required. So reboot I did.

When booting, after the mint logo shows up, I only get a blackscreen with a single white underscore at the top left. No key combinations save CTRL+ALT+DELETE+ENTER (reboot) work. Nothing happens.

In recovery mode, I tried, among all other options, the option to fix broken packages. After doing this and choosing "Resume normal boot" after a bunch of scrollin down messages (in the GRUB manager Id changed quiet splash to text) I get a black screen covering a blue screen message with an OK prompt at the bottom regarding something with the X-server not being able to be setup that pops up for a split second, and when I press enter I get the following X Server info (only typing what I assume to be relevant, if you need more info to resolve my problem I can type out the rest):

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
Current Operating System: Linux marvin-desktop 4.4.0-53-generic
Kernel command line...
Build Date: ....
xorg-server 2:1.18:4-0ubuntu0.2 ....
Current version of pixman: 0.33.6
...
Markers: <explanation> (== -> default setting, WW -> warning)
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Sep 2 02:33:33 2018
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
modprobe: FATAL: Module fglrx not found in directory /lib/modules/4.4.0-53-generic
(WW) fglrx: No matching Device section for instance ( BusID PCI: 0@1:0:1) found
modprobe: FATAL: Module fglrx not found in directory /lib/modules/4.4.0-53-generic
*** Error in '/usr/lib/xorg/Xorg': realloc(): invalid old size: 0x00007f9d77c274d0 ***

And then a long Backtrace.

After I press I get:

Would you like to view the detailed X server output as well? <Yes> <No>

Yes yields the same thing as before with more (WW)arnings regarding stuff like font directories not existing, I can provide specifics if needed.

<EXIT>

The X Server is now disabled. Restart MDM when it is configured correctly.

The joke is that after pressing Enter on this message, I get a blackscreen again, this time with a BIGGER white underscore that BLINKS. This is where I am stuck.

Also tried: In recovery mode, started root shell, entered dpkg -l xorg Which yields tons of versions of xserver-xorg-v. Attempting to purge results in dpkg -P xserver-xorg-v dpkg: error: unable to access dpkg status area: Read-only file system

0

It looks like your proprietary driver is not in the directory it's supposed to be in.

In recovery mode at the root shell move your custom /etc/X11/xorg.conf somewhere else and reboot. It should go back to defaulting to the old driver.

Do NOT mess around with purging packages unless it's the package of the proprietary drive you just installed that you now want to remove. But use the MINT package manager for that, don't randomly purge packages with dpkg, you'll in all likelihood just end up making things worse.

  • thanks for the warning. I mved that file and it booted like normal. – intecht Sep 4 '18 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.