1

I'm new to linux based systems i guess mint is based on ubuntu. I hope it's a right place for this question. I have a old laptop and it was really slow so i decided to install mint. I have single physical drive and it was splitted as a local disk C and local disk D windows was installed on local disk C. I removed all partitions except local disk D (because i don't want to lose all of my pictures and video archive) which it's ntfs and i create three different partitions for mint. One partition is ext4 partition for mint installation, second partition is a swap partition it's have a 16gb size and last one is a efi partition it has a 1gb size. I succesfully installed mint and restart my computer (i removed usb boot stick) it's telling me No bootable device -- instert boot disk and press any key. I checked bios boot options too top one is a EFI Ubuntu there is no other choice related with ubuntu. I couldn't figure it out. Here some pictures from my partitions and bios : My Partitions : https://prnt.sc/kpjho9 https://s33.postimg.cc/6w5wuishr/20180901_235810.jpg My bios boot section : https://s33.postimg.cc/asj8qll7z/20180901_235356.jpg And boot error : https://s33.postimg.cc/xv9rpbrpr/20180901_235341.jpg

I think something wrong with my partitions. Here is a screenshot from gparted : https://s33.postimg.cc/owjpcfzq7/20180902_015452.jpg

  • Did you install / configure a boot loader (e.g. GRUB / GRUB2)? – RudiC Sep 1 '18 at 22:21
  • @RudiC When i try to install it first time it give me an error about grub. This exact error 'grub-efi-amd64-signed failed to install' but after second try it didn't give me any error. I think i have a problem with grub. How can i install or configure it for installed mint ? – sword1st Sep 1 '18 at 22:29
0

The problem is that the EFI firmware in your machine can't find the EFI System Partition (ESP). You should preferably have partitioned your disk using the GPT partitioning scheme. The UEFI specification allows for using the MBR/DOS partitioning scheme, but then the ESP should be a primary partition, have the right type and have the bootable flag set. See also this U&L question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.