If I view man pages using info (e.g. info man), I see common hyperlinks (e.g. apropos(1)).

However, Texinfo commands that create hyperlinks (e.g. @xref), in Info output, add a label (*Note) before the name of an hyperlink.

Concretely, @xref{Node name}. produces *Note Node name::. but I would like to get Node name. (without the inserted *Note).

How can I get common hyperlinks in Info manuals?

  • Sure - with an @anchor. Gotta read the documentation, no cut/paste necessary... – Thomas Dickey Sep 1 '18 at 17:57
  • @ThomasDickey \@anchor just provides a place for me to jump to later. The text * Note still shows when I use an anchor. (If you meant something else, could you please elaborate?) – rahul Sep 2 '18 at 9:47
  • @Fólkvangr I was hoping for a source based solution, but will accept configuring the Info as the last ditch. Further, I could not get your solution to work too -- see my comment. – rahul Sep 3 '18 at 7:22

There are two primary Info readers: info, a stand-alone program designed just to read Info files (see What is Info?) and the info package in GNU Emacs, a general-purpose editor.

The stand-alone Info reader (greater or equal to version 6.0) may be configured to hide some information (related to note and menu items).

For more information, look at the GNU Info manual, more precisely, look at chapter "Manipulating Variables" (hide-note-references) and look at chapter "Custom Key Bindings", section "infokey format" (last paragraphs).

prompt% info info hide-note-references
prompt% nano ~/.infokey
prompt% cat ~/.infokey

GNU Emacs (Info mode) may also be configured to hide some informations (related to note and menu items), setting the variable Info-hide-note-references¹, in an Emacs initialization file (see GNU Emacs, chapter "Customization").

¹ Feature available in Texinfo, since version 4.8 (2005).

  • I could not get this to work on my info, which is in OSX (5.2). The manual also does not have a section on 'hide-note-references' inside Custom Key BIndings. I also tried M-x set-variable which does not seem to accept hide-note-references. Is this a new variable? – rahul Sep 3 '18 at 7:19
  • Ah, as I mentioned above, the Info version is 5.2 in OSX. So that is probably the reason. – rahul Sep 3 '18 at 9:26
  • Accepting this since it is closest to what I want. – rahul Sep 4 '18 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.