1

I've been running xcfe4 for a long time with no problems under linux.

Today I was making some changes to grub and doing some reboots to test it. Now, every time I enter my login password via the lightdm login screen, xfce4 pops up a dialog which prompts me to choose between logging out or entering a new session name. I have to either double-click on Default or enter some random text as the session name in order to get past this screen.

This never used to happen before. I'm guessing that one of my recent reboots left my xfce4 session in some sort of incomplete state, and now I am always given this dialog upon logging in after shutdown or reboot.

This even occcurs if I do a normal logout from xfce4 without a shutdown or reboot.

I didn't change anything in my settings, neither concerning logins or sessions, nor anything else.

Does anyone know how to disable this popup, so that once again I simply get my standard xfce4 session after login?

Thank you in advance.

migrated from serverfault.com Sep 1 '18 at 1:10

This question came from our site for system and network administrators.

2

I solved it: I had to go to Settings->Settings Editor->xfce4-session. The chooser attribute had AlwaysDisplay checked. I unchecked it and exited from Settings. Then, after shutdown, reboot, and logout, I am no longer prompted for a session.

I have no idea how that setting changed from its earlier value. But anyway, all's well that ends well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.