1

I have a clean Debian Stretch installation. It used to be the case that after booting I would end up on tty1 with a login prompt, and after logging X is started. I wanted to automate the logging in (because I'm the only user and my disk is encrypted already) so I followed the exact instructions given here:

  • In /etc/systemd/logind.conf, changed #NAutoVTs=6 to NAutoVTs=1
  • Used systemctl edit getty@tty1 and added (where username is my username):

    [Service]
    ExecStart=
    ExecStart=-/sbin/agetty --autologin username --noclear %I 38400 linux
    
  • Enabled the service: systemctl enable getty@tty1.service

After rebooting, the login prompt was gone from tty1 and nothing else happened. It still showed the boot log. On tty2-5, only a cursor appeared, no login prompt as before. Luckily, tty6 was still available to recover the system. So I did:

  • Disable the service: systemctl disable getty@tty1.service
  • Undid the change to /etc/systemd/logind.conf

Now, I can use all ttys except tty1 to login as normally, but somehow tty1 remains damaged. How can I repair this as well?

0
1

You should enable the getty@tty1.service again:

systemctl enable getty@tty1.service
1
  • I'm on Arch Linux where I also have a disabled tty1. I tried the above instructions, but it doesn't enable tty1 for me. May 13 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy