1

Recently my system starts behaving not normal and I'm getting some crashes. Currently I'm running:

ola@station:~$ uname -a
Linux thinkstation 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64 GNU/Linux

I got sever kernel crashes during the last couple of weeks. The last one this morning:

ola@station:~$ last | head -n 50
nicolas  tty7         :0               Fri Aug 31 08:34   still logged in
reboot   system boot  4.9.0-8-amd64    Fri Aug 31 08:32   still running
nicolas  tty7         :0               Fri Aug 31 08:22 - crash  (00:09)
reboot   system boot  4.9.0-8-amd64    Fri Aug 31 08:20   still running
nicolas  tty7         :0               Thu Aug 30 20:28 - 20:42  (00:14)
reboot   system boot  4.9.0-8-amd64    Thu Aug 30 20:27 - 20:43  (00:15)
nicolas  tty7         :0               Thu Aug 30 17:50 - crash  (02:36)
reboot   system boot  4.9.0-8-amd64    Thu Aug 30 17:49 - 20:43  (02:53)

I was then looking at the kern.log showing the following output:

  Aug 31 08:21:08 thinkstation kernel: [    8.755010] ioatdma 0000:00:16.6: enabling device (0000 -> 0002)
Aug 31 08:21:08 thinkstation kernel: [    8.755238] ioatdma 0000:00:16.6: can't derive routing for PCI INT C
Aug 31 08:21:08 thinkstation kernel: [    8.755239] ioatdma 0000:00:16.6: PCI INT C: no GSI
Aug 31 08:21:08 thinkstation kernel: [    8.769041] ioatdma 0000:00:16.7: enabling device (0000 -> 0002)
Aug 31 08:21:08 thinkstation kernel: [    8.769387] ioatdma 0000:00:16.7: can't derive routing for PCI INT D
Aug 31 08:21:08 thinkstation kernel: [    8.769390] ioatdma 0000:00:16.7: PCI INT D: no GSI
Aug 31 08:21:08 thinkstation kernel: [    8.780236] sd 0:0:0:0: Attached scsi generic sg0 type 0
Aug 31 08:21:08 thinkstation kernel: [    8.780268] sr 1:0:0:0: Attached scsi generic sg1 type 5
Aug 31 08:21:08 thinkstation kernel: [    8.785251] ACPI Warning: SystemIO range 0x0000000000001028-0x000000000000102F conflicts with OpRegion 0x0000000000001000-0x000000000000102F (\_SB.PCI0.LPC0.PMIO) (20160831/utaddress-247)
Aug 31 08:21:08 thinkstation kernel: [    8.785256] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Aug 31 08:21:08 thinkstation kernel: [    8.785259] ACPI Warning: SystemIO range 0x00000000000011B0-0x00000000000011BF conflicts with OpRegion 0x0000000000001180-0x00000000000011BF (\_SB.PCI0.LPC0.PSDT) (20160831/utaddress-247)
Aug 31 08:21:08 thinkstation kernel: [    8.785262] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Aug 31 08:21:08 thinkstation kernel: [    8.785262] ACPI Warning: SystemIO range 0x0000000000001180-0x00000000000011AF conflicts with OpRegion 0x000000000000118C-0x000000000000118F (\GPLV) (20160831/utaddress-247)
Aug 31 08:21:08 thinkstation kernel: [    8.785265] ACPI Warning: SystemIO range 0x0000000000001180-0x00000000000011AF conflicts with OpRegion 0x0000000000001198-0x000000000000119B (\BLNK) (20160831/utaddress-247)
Aug 31 08:21:08 thinkstation kernel: [    8.785268] ACPI Warning: SystemIO range 0x0000000000001180-0x00000000000011AF conflicts with OpRegion 0x0000000000001180-0x00000000000011BF (\_SB.PCI0.LPC0.PSDT) (20160831/utaddress-247)
Aug 31 08:21:08 thinkstation kernel: [    8.785271] ACPI Warning: SystemIO range 0x0000000000001180-0x00000000000011AF conflicts with OpRegion 0x0000000000001180-0x00000000000011AF (\_SB.PCI0.LPC0.GPOX) (20160831/utaddress-247)
Aug 31 08:21:08 thinkstation kernel: [    8.785273] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Aug 31 08:21:08 thinkstation kernel: [    8.785274] lpc_ich: Resource conflict(s) found affecting gpio_ich
Aug 31 08:21:08 thinkstation kernel: [    8.808030] input: PC Speaker as /devices/platform/pcspkr/input/input7
Aug 31 08:21:08 thinkstation kernel: [    8.910764] iTCO_vendor_support: vendor-support=0
Aug 31 08:21:08 thinkstation kernel: [    8.954911] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.11
Aug 31 08:21:08 thinkstation kernel: [    8.954942] iTCO_wdt: Found a ICH10R TCO device (Version=2, TCOBASE=0x1060)
Aug 31 08:21:08 thinkstation kernel: [    8.955030] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
Aug 31 08:21:08 thinkstation kernel: [    9.617979] snd_hda_intel 0000:03:00.1: Disabling MSI
Aug 31 08:21:08 thinkstation kernel: [    9.617986] snd_hda_intel 0000:03:00.1: Handle vga_switcheroo audio client
Aug 31 08:21:08 thinkstation kernel: [    9.638662] kvm: VM_EXIT_LOAD_IA32_PERF_GLOBAL_CTRL does not work properly. Using workaround
Aug 31 08:21:08 thinkstation kernel: [    9.738308] media: Linux media interface: v0.10
Aug 31 08:21:08 thinkstation kernel: [    9.904055] Adding 19529724k swap on /dev/sda5.  Priority:-1 extents:1 across:19529724k FS
Aug 31 08:21:08 thinkstation kernel: [   10.003509] Linux video capture interface: v2.00
Aug 31 08:21:08 thinkstation kernel: [   10.054798] snd_hda_codec_analog hdaudioC0D2: autoconfig for AD1988: line_outs=4 (0x12/0x16/0x24/0x25/0x0) type:line
Aug 31 08:21:08 thinkstation kernel: [   10.054800] snd_hda_codec_analog hdaudioC0D2:    speaker_outs=1 (0x13/0x0/0x0/0x0/0x0)
Aug 31 08:21:08 thinkstation kernel: [   10.054802] snd_hda_codec_analog hdaudioC0D2:    hp_outs=1 (0x11/0x0/0x0/0x0/0x0)
Aug 31 08:21:08 thinkstation kernel: [   10.054803] snd_hda_codec_analog hdaudioC0D2:    mono: mono_out=0x0
Aug 31 08:21:08 thinkstation kernel: [   10.054804] snd_hda_codec_analog hdaudioC0D2:    dig-out=0x1b/0x0
Aug 31 08:21:08 thinkstation kernel: [   10.054805] snd_hda_codec_analog hdaudioC0D2:    inputs:
Aug 31 08:21:08 thinkstation kernel: [   10.054807] snd_hda_codec_analog hdaudioC0D2:      Front Mic=0x14
Aug 31 08:21:08 thinkstation kernel: [   10.054808] snd_hda_codec_analog hdaudioC0D2:      Rear Mic=0x17
Aug 31 08:21:08 thinkstation kernel: [   10.054809] snd_hda_codec_analog hdaudioC0D2:      Line=0x15
Aug 31 08:21:08 thinkstation kernel: [   10.054810] snd_hda_codec_analog hdaudioC0D2:    dig-in=0x1c
Aug 31 08:21:08 thinkstation kernel: [   10.069621] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
Aug 31 08:21:08 thinkstation kernel: [   10.069980] input: HDA Intel Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
Aug 31 08:21:08 thinkstation kernel: [   10.070038] input: HDA Intel Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
Aug 31 08:21:08 thinkstation kernel: [   10.070419] input: HDA Intel Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
Aug 31 08:21:08 thinkstation kernel: [   10.070546] input: HDA Intel Line Out Front as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
Aug 31 08:21:08 thinkstation kernel: [   10.070681] input: HDA Intel Line Out Surround as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
Aug 31 08:21:08 thinkstation kernel: [   10.070781] input: HDA Intel Line Out CLFE as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
Aug 31 08:21:08 thinkstation kernel: [   10.070875] input: HDA Intel Line Out Side as /devices/pci0000:00/0000:00:1b.0/sound/card0/input15
Aug 31 08:21:08 thinkstation kernel: [   10.070980] input: HDA Intel Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input16
Aug 31 08:21:08 thinkstation kernel: [   10.429417] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:07.0/0000:03:00.1/sound/card1/input17
Aug 31 08:21:08 thinkstation kernel: [   10.429481] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:07.0/0000:03:00.1/sound/card1/input18
Aug 31 08:21:08 thinkstation kernel: [   10.429534] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:07.0/0000:03:00.1/sound/card1/input19
Aug 31 08:21:08 thinkstation kernel: [   11.204717] usb 2-1: set resolution quirk: cval->res = 384
Aug 31 08:21:08 thinkstation kernel: [   11.205098] usbcore: registered new interface driver snd-usb-audio
Aug 31 08:21:08 thinkstation kernel: [   11.205169] uvcvideo: Found UVC 1.00 device <unnamed> (046d:0825)
Aug 31 08:21:08 thinkstation kernel: [   11.219871] uvcvideo 2-1:1.0: Entity type for entity Extension 4 was not initialized!
Aug 31 08:21:08 thinkstation kernel: [   11.219875] uvcvideo 2-1:1.0: Entity type for entity Extension 6 was not initialized!
Aug 31 08:21:08 thinkstation kernel: [   11.219878] uvcvideo 2-1:1.0: Entity type for entity Extension 7 was not initialized!
Aug 31 08:21:08 thinkstation kernel: [   11.219881] uvcvideo 2-1:1.0: Entity type for entity Processing 2 was not initialized!
Aug 31 08:21:08 thinkstation kernel: [   11.219883] uvcvideo 2-1:1.0: Entity type for entity Extension 3 was not initialized!
Aug 31 08:21:08 thinkstation kernel: [   11.219886] uvcvideo 2-1:1.0: Entity type for entity Camera 1 was not initialized!
Aug 31 08:21:08 thinkstation kernel: [   11.220042] input: UVC Camera (046d:0825) as /devices/pci0000:00/0000:00:1d.7/usb2/2-1/2-1:1.0/input/input20
Aug 31 08:21:08 thinkstation kernel: [   11.220172] usbcore: registered new interface driver uvcvideo
Aug 31 08:21:08 thinkstation kernel: [   11.220172] USB Video Class driver (1.1.1)
Aug 31 08:21:08 thinkstation kernel: [   11.922656] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
Aug 31 08:21:13 thinkstation kernel: [   21.053499] IPv6: ADDRCONF(NETDEV_UP): enp5s0: link is not ready
Aug 31 08:21:13 thinkstation kernel: [   21.104025] IPv6: ADDRCONF(NETDEV_UP): enp5s0: link is not ready
Aug 31 08:21:14 thinkstation kernel: [   21.447716] usb 2-1: reset high-speed USB device number 2 using ehci-pci
Aug 31 08:21:17 thinkstation kernel: [   24.749217] tg3 0000:05:00.0 enp5s0: Link is up at 1000 Mbps, full duplex
Aug 31 08:21:17 thinkstation kernel: [   24.749227] tg3 0000:05:00.0 enp5s0: Flow control is off for TX and off for RX
Aug 31 08:21:17 thinkstation kernel: [   24.749244] IPv6: ADDRCONF(NETDEV_CHANGE): enp5s0: link becomes ready
Aug 31 08:21:19 thinkstation kernel: [   26.431300] nvidia-modeset: Allocated GPU:0 (GPU-65b14185-712c-78ee-cb6b-ad7301f6cc85) @ PCI:0000:03:00.0
Aug 31 08:21:25 thinkstation kernel: [   32.972477] fuse init (API version 7.26)
Aug 31 08:21:30 thinkstation kernel: [   38.196407] aufs 4.9-20161219
Aug 31 08:21:31 thinkstation kernel: [   39.260303] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
Aug 31 08:21:31 thinkstation kernel: [   39.260889] Bridge firewalling registered
Aug 31 08:21:31 thinkstation kernel: [   39.304259] nf_conntrack version 0.5.0 (65536 buckets, 262144 max)
Aug 31 08:21:32 thinkstation kernel: [   39.656300] Initializing XFRM netlink socket
Aug 31 08:21:32 thinkstation kernel: [   39.660384] Netfilter messages via NETLINK v0.30.
Aug 31 08:21:32 thinkstation kernel: [   39.674068] ctnetlink v0.93: registering with nfnetlink.
Aug 31 08:21:32 thinkstation kernel: [   39.778095] IPv6: ADDRCONF(NETDEV_UP): docker0: link is not ready
Aug 31 08:22:18 thinkstation kernel: [   86.563082] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 28
Aug 31 08:22:18 thinkstation kernel: [   86.887039] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 22
Aug 31 08:22:18 thinkstation kernel: [   86.959055] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 3
Aug 31 08:32:23 thinkstation kernel: [    0.000000] Linux version 4.9.0-8-amd64 (debian-kernel@lists.debian.org) (gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) ) #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21)

The last message before rebooting was the ` Aug 31 08:22:18 thinkstation kernel:

[   86.959055] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 3 

I'm not sure if this was causing the crash or the ACPI warnings I get above :

Aug 31 08:32:23 thinkstation kernel: 
[   10.316100] ACPI Warning: SystemIO range 0x0000000000001180-0x00000000000011AF conflicts with OpRegion 0x0000000000001180-0x00000000000011AF (\_SB.PCI0.LPC0.GPOX) (20160831/utaddress-247)

Does someone know what could cause the problem? If it is the snd_hda_codec_hdmi how can I resolve it?

  • First this: run a memory test: apt-get install memtest86+, reboot, choose “Memory test” at the Grub prompt, and wait for at least one full pass. – Gilles Aug 31 '18 at 7:36
  • @Gilles ok, let me do that right away. thx for the comment. I will post the results – math Aug 31 '18 at 7:37
  • The only thing evident from the logs is that you need a BIOS update. As for the crashes, we have not enough data. However, you are not telling us the whole context. If this is a machine doing bridge and bridge only, I would disable the graphical interface, the sound card, the camera... As Gilles suggests, is also a good idea to check the RAM health when machines are misbehaving. – Rui F Ribeiro Aug 31 '18 at 7:38
  • 1
    After including it check if it is not running on lsmod | grep snd_hda_codec_hdmi – Luciano Andress Martini Aug 31 '18 at 12:10
  • 1
    @Gilles ive let it run over the weekend and it passed 21 without any errors. I guess this is not a memory issue – math Sep 2 '18 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.