0

In my windows, I have created a folder. I have mounted that folder using curlftps. It was successful. there's a .iso file (centos.iso) in that folder. Then I tried to mount that iso image to my linux again in a mount point. But it was unsuccessful.

root@UbuntuServer:/mnt/test# mount -o loop CentOS-7-x86_64-Everything-1804.iso /mnt/test2/
mount: /mnt/test/CentOS-7-x86_64-Everything-1804.iso: failed to setup loop device: Operation not supported  


root@UbuntuServer:~# curlftpfs ftp://randeer:randeer@192.168.0.2 /mnt/test/
root@UbuntuServer:~# ls -l
total 0
root@UbuntuServer:~# cd /mnt/test/
root@UbuntuServer:/mnt/test# ls
CentOS-7-x86_64-Everything-1804.iso  new public             rootnewprivate.ppk
fromcentos.txt                       randeernewprivate.ppk  rootpub
root@UbuntuServer:/mnt/test# mount CentOS-7-x86_64-Everything-1804.iso /mnt/test                                                                                        2/ -t iso9600 -o loop
mount: /mnt/test/CentOS-7-x86_64-Everything-1804.iso: failed to setup loop device

my screenshot

  • 1
    Hello, Lets get a little more information. What version of mount are you using? mount --version. What is currently mounted, do you need a remount? mount. Try the mount command again with the verbose switch. sudo mount --verbose -o loop /path/centOS.iso /mnt/test2. Post the outputs in text... – jc__ Aug 30 '18 at 13:53
  • @jc__ - I ran the command as u specify early. but it didn't give me any specific details. root@UbuntuServer:~# curlftpfs test:test@192.168.0.2 /mnt/test/ root@UbuntuServer:~# ls /mnt/test/ CentOS-7-x86_64-Everything-1804.iso test.txt root@UbuntuServer:~# mount --verbose -o loop /mnt/test/CentOS-7-x86_64-Everything-1804.iso /mnt/test2 mount: /mnt/test/CentOS-7-x86_64-Everything-1804.iso: failed to setup loop device: Operation not supported – Randeer Lalanga Aug 31 '18 at 3:59
  • mount version is : mount from util-linux 2.27.1 (libmount 2.27.0: selinux, assert, debug) – Randeer Lalanga Aug 31 '18 at 4:28
1

curlftps is userspace, mount loopback is kernelspace. Kernel can't see the userspace mounted file. Use fuseiso for mounting which is a userspace based solution.

  • Thanks mate, it works. 1)apt install fuseiso . 2) modprobe fuse 3)mkdir /mnt/iso 4)fuseiso -p /mnt/test/CentOS-7.iso /mnt/iso/ – Randeer Lalanga Aug 31 '18 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.