3

My laptop is Dell Inspiron 5420, with two graphic cards:

  • Intel HD Graphics 4000
  • Nvidia GeForce GT 630M

I took the Thinkpad T400 configuration guide as an example to configure my Linux, but I only get the integrated card to work, and the card is not using the Intel driver

Currently, the behavior of my system is:

  • using the intel driver in the Xorg.config, X cannot starts, reports cannot find the device
  • using the vesa driver, the X could work, but no advanced graphic features, which means Gnome 3 is not available
  • using the nvidia / nouveau driver, according to the log, the X seems to be started, but I got a black screen with nothing

If you know a better guide/example to configure the system, please let me know. If you need my Xorg.config, I will post it.

5

As far as I can tell from your problem description the correct term for what you want is "hybrid graphics" as you only use either adapter to power your monitor (actually any output), not both at the same time.

An overview over tools for what you want can be found (for example) here. You may be looking for the tool bbswitch from the Bumblebee-Project. Yet, you should not put anything about drivers into your xorg.conf. X should find and load the correct drivers itself. Also, I remember reading something about improved support for hybrid graphics in the most recent stable kernel, so you should get/build the most recent stable kernel for your distro. You may find more on the internet by the term "hybrid graphics" anyways.

Hope that helps.

  • IIRC this is also what is called "Optimus" by nVidia. From what I know so far (put a grain of salt to it) is that Optimus still is problematic under Linux. – user86969 Aug 28 '15 at 9:53
0

what you need sounds like the bumblebee package. Bumblebee basically decides which graphics card to use if you tell bumblebee to decide for you.

How to install: (detailed guide, please CAREFULLY read)

https://wiki.archlinux.org/index.php/Bumblebee

Installation overview and explanation:

Install the needed packages via your package manager:

  • assuming you are on a 64bit-system and want to run 32-bit applications (not exclusively, but also). If not, you do not need to install any of the packages beginning with lib32 so called mutilib packages.
  • Be aware that you might need to add mutilib sources for you package manager in order to be able to download them (depending on your package manager).
  • pacman is a package manager, yours could be e.g. apt or yum etc.

pacman -S bumblebee mesa mesa-demos xf86-video-intel lib32-virtualgl lib32-nvidia-utils lib32-mesa-libgl

Be aware of:

  • Do NOT install nvidia-libgl this might cause a blackscreen or worse at startup!
  • Do NOT run the nvidia X server settings application and not nvidia-xconfig
    • If you do so the X will fail at target graphical interface reached
    • Here's how to resolve this issue: mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
    • reason: xorg.conf is not needed for the default intel card.

After installation:

  • Activate the bumblebee daemon via sudo systemctl enable bumblebeed.service (Mind the d at the end!)
  • sudo reboot now

Usage example:

optirun <your application>

although in most cases primusrun is preferable:

primusrun <your application>

The reason is it avoids some of optiruns overhead and thus is more performant.

To check the status of bumblebee while running:

optirun --status

It should say something like: Bumblebee status: Ready (3.2.1). X is PID 26489, 1 applications using bumblebeed.

Anomaly: it seems depending on which linux kernel you use, switching off the nvidia-card again might prove a hard thing to do. Shouldnt bother you though except if power-consumption is crucial, then you gotta reboot.

Please ask if you have any questions or can contribute to improve this answer.

0

Here is a suggestion for installing OpenSUSE Tumbleweed (as of April 2019) on a recent PC (Asus G20) with both Intel & nVidia (GTX970) graphics controllers:

  • in the BIOS settings, BOOT parameters, you can continue to use UEFI mode, but change the OS from "Windows" to "Other OS"

  • if your installation of OpenSUSE crashes, hangs, or fails with an unexpected error, try adding these options to the kernel boot line (press 'e' in the Grub boot screen): textmode=1 nomodeset acpi=off splash=verbose

  • you may need to do this each time when you run the 'Installation' or 'Update' option

  • after installing on an Asus G20, the following kernel options are recommended permanently, which you can set in Yast, Boot, Kernel parameters: pci=acpi pci=noaer splash=silent

  • also, it is suggested to install a minimum system in the non-graphics mode first, just to get the system running, then download the nVidia drivers for X using Yast from the Nvidia OpenSUSE repo, which is described here: https://en.opensuse.org/SDB:NVIDIA_drivers

  • install the appropriate for your graphics card. I used for a GTX970:

  • install the 'x11-video-nvidiaG05' driver, then reboot
  • install the 'nvidia-glG05' for OpenGL 3D acceleration

  • then run 'Update' to bring the system up to graphics mode

This problem was submitted to OpenSUSE.

Possible causes: - PCI Advaced Error Reporting (AER) floods the system log - possible conflicts between the Intel and nVidia controllers prior to nVidia drivers being installed cause crash

[end]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.