0

I'm trying to install a new version of RabbitMQ on my Raspberry Pi 3, running a new raspbian image (based on debian 9).

I was following the installation guide for Debian/Ubuntu, which worked for me on Ubuntu 18.04, but not on raspbian: https://www.rabbitmq.com/install-debian.html

Whatever I tried to do according to the guide to force the use of their own repository (creating /etc/apt/sources.list.d/bintray.erlang.list and /etc/apt/preferences.d/erlang), when I do apt-get install erlang-nox I get a version 19.2.1 from another repository. This version does not work with newer rabbitmq-server releases, and has security holes too.

So now instead, I want to manually install the erlang-nox packages, found here on the rabbitmq repository: http://dl.bintray.com/rabbitmq/debian/pool/erlang/21.0.5-1/debian/stretch/

How could I download the packages and install them all at once? Do I have to copy paste the name of all of these?

Edit: I noticed there is a erlang_21.0.5-1_all.deb package at the bottom of the list, tried to download it and install it, but as it turns out it does not contain all the packages at all, it is only 36 KB.

0

You should try

apt update
apt install erlang

If that doesn't work, you could download the erlang_21.0.5-1_all.deb package, install it with

dpkg -i erlang_21.0.5-1_all.deb

It will fail because of missing dependencies, that's okay, here's how you ask apt to fetch these for you:

apt -f install
  • Sadly these did not work, for now I just installed an old version of rabbitmq-server (3.6.12) – Zoltán Umlauf Aug 29 '18 at 11:15
0

Add the erlang repo:

# cat << EOF  | tee /etc/apt/sources.list.d/rabbitmq.list
deb http://dl.bintray.com/rabbitmq/debian/ stretch erlang
EOF

Or simply add the following line to /etc/apt/sources.list :

deb http://dl.bintray.com/rabbitmq/debian/ stretch erlang

Get the signing key:

#  wget -O - 'https://dl.bintray.com/rabbitmq/Keys/rabbitmq-release-signing-key.asc' | apt-key add -

Then:

# apt update
$ apt-cache policy erlang-nox

Install the specific version :

# apt install erlang-nox=1:21.0.5-1

apt will install the erlang-nox package with its dependencies.

RabbitMQ: Installing on Debian and Ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.