1

Today, GNOME Software showed a software update notification. I ran pkcon update, but there were no updates in PackageKit.

I thought that meant it was an update to a Flatpak app. So I opened GNOME Software, but it did not show any updates. Even after clicking the refresh button.

However there are flatpak updates:

$ flatpak update
Looking for updates...
Installing in system:
org.kde.KStyle.Adwaita/x86_64/5.11              flathub e57166147180
org.kde.Platform.Locale/x86_64/5.11             flathub f088e9aca35b
org.freedesktop.Platform.VAAPI.Intel/x86_64/1.6 flathub 82006efc71d3
org.freedesktop.Platform.ffmpeg/x86_64/1.6      flathub d757f762489e
org.kde.KStyle.Adwaita/x86_64/5.9               flathub 41f06d286c71
org.kde.Platform.Locale/x86_64/5.9              flathub 419358ad4f0a
Updating in system:
io.github.wereturtle.ghostwriter/x86_64/stable flathub 554be79e1d31
Is this ok [y/n]: n

Why would GNOME Software not show these updates?

All the Flatpak apps were installed using Gnome Software, not directly with flatpak commands.

I don't know if I have ever installed an update to Flatpak app. I only tried using them recently. (I.e. from my point of view this isn't a regression; it might never have worked).


$ rpm -q gnome-software flatpak
gnome-software-3.28.2-1.fc28.x86_64
flatpak-1.0.0-2.fc28.x86_64

$ head -n2 /usr/lib/os-release 
NAME=Fedora
VERSION="28 (Workstation Edition)"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.