1

I recently got a new laptop (Thinkpad T480) which has Intel integrated "UHD Graphics 620" and an Nvidia MX150, and I installed Ubuntu 18.04. I installed the nvidia driver alright, and I believe I am using the Nvidia card successfully to run my laptop's display/external monitors.

However, I have a problem displaying 3D content: when I try to create a 3D plot in Mathematica, the program simply crashes (this does not happen when I switch back to using my Intel card with prime-select). Furthermore, when I try to launch Steam, I get the error "OpenGL GLX extension not supported by display" (and again this does not occur and steam works normally when I use my integrated graphics). Finally, with the nvidia card selected, I am unable to even login to the standard gnome desktop environment (I simply get booted back out to the login screen). Luckily I normally use xmonad, and that seems to work fine.

I tried reinstalling xserver-xorg which was suggested somewhere online but that didn't help. I saw other information about installing Bumblebee, but all of that seems to be from many years ago (and the latest release of Bumblebee is over 5 years old so I was a little wary about it). Nevertheless, I tried installing Bumblebee and, after modifying /etc/bumblebee/bumblebee.conf to use the correct directory for the libGL.so.1 driver, I was able to run a game through Steam. I never tried running Steam itself using optirun but I ran Civilization V with optirun through Steam and it seemed to work as intended, and I could see that the Nvidia card was being used with the program NVTOP. Civilization V does involve 3D graphics but I'm not sure if it uses OpenGL. I also tried running Minecraft (which I think does use OpenGL) through optirun and just got a window with a black screen. I tried optirun glxgears and got an error that said

X Error of failed request: BadMatch (invalid parameter attributes)

I did some more research and found that perhaps Bumblebee was not the way to go (multiple reports of bugs with Ubuntu 18.04)... so now I am back in the situation I described in the first and second paragraphs above. I figured it was time to ask for help.

Below are the outputs to some commands I have seen in other questions related to this issue:

Here is my output when I try to run glxinfo:

name of display: :0
Error: couldn't find RGB GLX visual or fbconfig

Here is my output when I try to run glxgears:

Error: couldn't get an RGB, Double-buffered visual

Here is my output when I run lspci -nnnk | grep "VGA\|'Kern'\|3D\|Display" -A2:

00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
Subsystem: Lenovo UHD Graphics 620 [17aa:225e]
Kernel driver in use: i915
--
01:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX150] [10de:1d10] (rev a1)
Subsystem: Lenovo GP108M [GeForce MX150] [17aa:225e]
Kernel driver in use: nvidia
0

I tried again on a fresh install of Ubuntu 18.04 and installed the Nvidia driver before anything else, and that worked (everything seems to be working now). I believe something else I had previously installed (not sure what) was conflicting with some of the files required by my graphics setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.