1

I tried to use cpupower utility to manually set processor governor to performance. However, it seems that it has no effect!

# cpupower frequency-set -g performance
Setting cpu: 0
Setting cpu: 1
Setting cpu: 2
Setting cpu: 3
Setting cpu: 4
Setting cpu: 5
Setting cpu: 6
Setting cpu: 7
Setting cpu: 8
Setting cpu: 9
Setting cpu: 10
Setting cpu: 11
Setting cpu: 12
Setting cpu: 13
Setting cpu: 14
Setting cpu: 15
Setting cpu: 16
Setting cpu: 17
Setting cpu: 18
Setting cpu: 19
Setting cpu: 20
Setting cpu: 21
Setting cpu: 22
Setting cpu: 23
Setting cpu: 24
Setting cpu: 25
Setting cpu: 26
Setting cpu: 27
Setting cpu: 28
Setting cpu: 29
Setting cpu: 30
Setting cpu: 31
Setting cpu: 32
Setting cpu: 33
Setting cpu: 34
Setting cpu: 35
Setting cpu: 36
Setting cpu: 37
Setting cpu: 38
Setting cpu: 39
Setting cpu: 40
Setting cpu: 41
Setting cpu: 42
Setting cpu: 43
Setting cpu: 44
Setting cpu: 45
Setting cpu: 46
Setting cpu: 47
Setting cpu: 48
Setting cpu: 49
Setting cpu: 50
Setting cpu: 51
Setting cpu: 52
Setting cpu: 53
Setting cpu: 54
Setting cpu: 55
# lscpu | grep -E "(Model|CPU MHz)"
Model:                 63
Model name:            Intel(R) Xeon(R) CPU E5-2695 v3 @ 2.30GHz
CPU MHz:               2150.230
# lscpu | grep -E "(Model|CPU MHz)"
Model:                 63
Model name:            Intel(R) Xeon(R) CPU E5-2695 v3 @ 2.30GHz
CPU MHz:               1899.027
  • 1
    What makes you think it had no effect? – terdon Aug 28 '18 at 8:05
  • From Arch wiki : The intel_pstate driver supports only the performance and powersave governors, but they both provide dynamic scaling. – Kiwy Aug 28 '18 at 8:20
  • @terdon: As you can see in the output of lscpu, the value of CPU MHz is not constantly 2.3GHz – mahmood Aug 28 '18 at 8:43
  • It's important to know also that your CPU will prevent itself from overheating if it needs to lower its temperature. Even if you enforce a 100% CPU load and change the governor. For what do you need your CPU to be at 100% ? – Kiwy Aug 28 '18 at 10:24
  • @Kiwy: I want to measure the time in my allocation via rdscp() so I want to be sure that frequency is constant. – mahmood Aug 28 '18 at 10:33
1

Setting the governor to performance does not cause your CPU to constantly run at the highest MHZ possible! That would be a terrible and wasteful idea, as well as pointless. There is no reason for a CPU to run at maximum speed if it is not doing something intensive. You get no gain, and are just wasting power.

The governor will always set the speed of the CPU to the most appropriate level based on the current need and the governor setting. So, when you set it to performance, that means that it will always try to maximise performance over, for example, power conservation. This means that if you now launch a CPU-intensive task, you will see the speed of your CPU reach its maximum. But only when running something, not all the time!

This is because both the ondemand and the powersave governors provide dynamic scaling. As mentioned in the Arch wiki:

Note: The intel_pstate driver supports only the performance and powersave governors, but they both provide dynamic scaling. The performance governor should give better power saving functionality than the old ondemand governor.

  • What you say is called "on demand" governor. That is when the processor is idle, it goes to the lowest frequency and when it has to run something it switches to max frequency. With "power save" the cpu is constantly running of the lowest frequency regardless of its state. Even in windows you will see "performance", "balanced" and "power save". – mahmood Aug 28 '18 at 9:10
  • I want to test some cpu features, so I need to set the frequency to its max value – mahmood Aug 28 '18 at 9:11
  • 1
    @mahmood see update. The performance governor still provides dynamic scaling. The ondemand governor is no longer used by modern Intel CPUs. If you need to test your CPU, run stress or something like that. – terdon Aug 28 '18 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.