The server has two network interfaces: eth0 with direct IP = xxx.xx.xx.18 connected to provider, and eth1 with another direct IP = xxx.xx.xx.25

DNS for the zone is configured correctly and it associates the latter IP with the domain name = name.org

Emails sent to various online email services (incl. yahoo.com) are successfully delivered, but Gmail rejects emails with the following error:

<<< 550-5.7.1 [xxx.xx.xx.18] The IP you're using to send mail is not
authorized to 
<<< 550-5.7.1 send email directly to our servers. Please
use the SMTP relay at your 
<<< 550-5.7.1 service provider instead.
Learn more at 
<<< 550 5.7.1 
y76-v6si291845lfa.11 - gsmt p 
554 5.0.0 Service unavailable

My Internet provider says it configured PTR at their servers to point to my IP, which corresponds to my domain name, (i.e. xxx.xx.xx.25). They say it should help. So, the problem could be because Gmail sees my emails sent from xxx.xx.xx.18, but I can't understand why? xxx.xx.xx.18 is not resolved to my domain name (name.org).

Any ideas? Thanks in advance!

  • 1
  • What does your routing table look like? (Commands netstat -rn or route -n output?) If the default route is through the eth0 interface, then an outgoing connection to gmail smtp mx servers will most likely use the x.x.x.18 source IP... Maybe that's the issue? – filbranden Aug 28 '18 at 3:00
  • Filipe, xxx.xx.xx.16 U 1 0 0 eth0 | xxx.xx.xx.24 U 0 0 0 eth1 | U 1003 0 0 eth1 | xxx.xx.xx.17 UG 0 0 0 eth0 – Vlad Aug 28 '18 at 13:40
  • Steven, I need to configure mail to serve the needs of my web server applications, so emails sent from my server should be accepted by 99% of mail servers, incl. Gmail. Recently, my Internet provider closed the relay mail server, which was perfectly acknowledged by Gmail. Now, the provider is ready to do whatever is needed to help me with the mail. They asked for IP, from which all mail is sent. I provided the IP of my domain name xxx.xx.xx.25. Should I tell them to use xxx.xx.xx.18 now? Or should I change DNS or sendmail options? – Vlad Aug 28 '18 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.