2

I cannot use my wireless capabilities of my laptop at all.

I connect to my home router manually (without using the network manager, I purged it). Using the following commands:

ifconfig wlan0 up
wpa_supplicant -Dnl82011 -iwlan0 -c /etc/wpa_supplicant.conf

It says the wifi is connected. They in another terminal I say

dhclient -v wlan0

It gets an ip address after the first DHCPDISCOVER.

But then I cannot ping or anything. tcpdump says my computer is desperately sending ARPs to the get router's MAC but doesn't see a reply.

I can see these broadcasts from my desktop PC, so they are definitely put on the air. I can also broadcast ARP-s using the arpsend from my desktop computer and I see them on my laptop. I can even ask for my laptop's MAC address from my desktop using arpsend and my laptop replies those and the reply is received on the desktop computer.

But something swallows all packets directed specifically to the laptop, while the broadcast packets (like broadcast pings and arp broadcasts) are received.

If I try to use wired connection it works. Only the wireless is bad.

My iptables are empty so I have no active firewall that would block the traffic.

I even changed my MAC address slightly to make sure it's not my router wreaking havoc, but no avail.

I found nothing relevant on the internet, people usually have this problem with very complex networking setups only. And I'm here just wanting get my wifi work.

I totally ran out of ideas.

Any idea what can be the culprit?

  • Interesting problem. One possibility is a driver bug, so I'd google with your WLAN hardware/driver info to see if anything shows up. – dirkt Aug 28 '18 at 5:56
  • @dirkt This is a 10 year old NEC Versa one laptop. The wireless card is seen by the system as and usb wifi dongle (perhaps because t's soldered to an usb bus inside). The system knows it as MSI RT2573, and loads the rt73usb driver for it. It worked in Ubuntu 16.04 doesn't work after the update to 18.04 (which was done on wired connection). – Calmarius Aug 28 '18 at 9:51
  • rt73usb requires non-free firmware, you've also installed the new firmware packages? Any suspicious messages in dmesg after booting (like "wrong firmware version")? – dirkt Aug 28 '18 at 10:03
  • @dirkt The journalctl says it manages to load rt73.bin successfully. – Calmarius Aug 28 '18 at 19:12
  • 1
    I'm voting to close this question as off-topic because solving hardware issues is not a Unix software topic. – Isaac Aug 29 '18 at 2:41
1

Today I continued my investigation.

I selected an older kernel: no avail.

Then the next thing I tried: activated the mobile hotspot on my phone a try to connect to that. And it worked!

No way! My phone can connect to my router just fine, is it possible that my router somehow blocked my laptop or something? I checked the MAC banlist, they were empty. But still no avail.

Perhaps something is in the air. And indeed thats a possibility the laptop was on my desk, right next to my router, and the power cord splitter. Which can indeed cause interference or something like that. But how come the WPA handshake and DHCP succeeded? I don't know. Perhaps they are different packets and not lost in the interference.

Anyway I moved the laptop away from the wireless AP, I shut it down, removed the power brick. Since its battery was dead it forgot the CMOS settings and needed to set the date and time next time I booted up.

I tried again from there, and it worked!

So the possible things that could have been the culprit:

  • Interference
  • The wifi card don't like being shouted at by the wifi router from 30 cm.
  • CMOS reset fixed it.

Anyway for science I moved to my laptop again to my desk, to see if I again have problems.

But now didn't. I cannot reproduce it again.

It looks like something on my laptop entered in a latched up state and stayed like that until the next complete power cycle.

I'm working with computers for 15 years and never experienced a peculiar problem with symptoms like this before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.