0

My router has my network separated into two subnets - 192.168.1.0/24 for wired and 192.168.2.0/24 for wireless clients. My home server lives at 192.168.1.42 and is not reachable from a client on the wireless subnet. After checking that there are no firewall rules preventing this, I believe the issue has to do with the IP routes on my home server, but I am not sure how they got configured this way or what's the best way to reset them.

$ ip route
default via 192.168.1.1 dev eth0  proto static  metric 100
default via 192.168.2.10 dev enx00c0ca9150d0  proto static  metric 101
169.254.0.0/16 dev eth0  scope link  metric 1000
172.17.0.0/16 dev docker0  proto kernel  scope link  src 172.17.0.1 linkdown
172.18.0.0/16 dev br-04e97bd45b14  proto kernel  scope link  src 172.18.0.1
172.19.0.0/16 dev br-4446693f3776  proto kernel  scope link  src 172.19.0.1
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.42  metric 100
192.168.2.0/24 dev enx00c0ca9150d0  proto kernel  scope link  src 192.168.2.236  metric 100



$ ifconfig
enx00c0ca9150d0 Link encap:Ethernet  HWaddr <hwaddr>
          inet addr:192.168.2.236  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::f988:d8cd:a896:1a0d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31031 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37161 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1428566 (1.4 MB)  TX bytes:3642834 (3.6 MB)
eth0      Link encap:Ethernet  HWaddr <hwaddr>
          inet addr:192.168.1.42  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::d250:99ff:fe81:26ca/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:27145978 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25074194 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:18550324198 (18.5 GB)  TX bytes:20993111588 (20.9 GB)
          Interrupt:18

I believe the default 192.168.2.10 route for whatever interface enx00c0ca9150d0 is what's causing the problem, but I'm not sure what that interface is? Or why it has a routing for the 192.168.2.0/24 subnet.

  • are you using raspberrypi? – msp9011 Aug 27 '18 at 20:56
  • Okay, that's a good start. What OS is your home server running? I assume it does not have a WiFi interface, correct? Is KVM or another hypervisor running on your server? – 0xSheepdog Aug 27 '18 at 20:57
  • Not a raspberrypi, running Ubuntu 16.04. It does have a wifi interface that I've used occasionally, but that is turned off and under the interface wlan0 (I omitted it from the ifconfig output I pasted). No KVM or hypervisor, though I am running docker. – Ross Hettel Aug 27 '18 at 21:18
  • Your enx device has a MAC of 00:c0:ca:91:50:d0. Is this your (USB) wireless card? – roaima Aug 28 '18 at 22:02
0

Figured it out, forgot I had my wifi-pineapple plugged in and the internet connection sharing script apparently uses 192.168.2.1.

Not the answer you're looking for? Browse other questions tagged or ask your own question.