2

I just installed Linux Mint 19 Cinammon and I'm having issues with my mouse sensitivity being too low. I went to the options and tried to increase it but the slider is already at the "max" position. I saw online people suggesting that I edit my xorg file, but newer versions of Linux appear to not use one.

2

I had the exact opposite problem of this with Mint 18, but the solution should be essentially the same.

If you run xinput --list --short, you should get an output of peripherals connected along with their ID. We just want the mouse, so we can pipe it into a grep:

xinput --list --short | grep -i mouse
⎜ ↳ USB Optical Mouse id=8 [slave pointer (2)]

So the ID here is 8

We can now pull a bunch of configuration for that peripheral with --list-props:

xinput --list-props 8
Device 'USB Optical Mouse':
    Device Enabled (115):   1
    Coordinate Transformation Matrix (117): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (227):     0
    Device Accel Constant Deceleration (228):       1.000000
    Device Accel Adaptive Deceleration (229):       1.000000
    Device Accel Velocity Scaling (230):    10.000000

Velocity Scaling is the one you'll want to change to get a better DPI with your mouse. you can see the ID of that in my output is 230 and it's value is 10.00

You can change the setting with --set-prop as below:

xinput --set-prop <mouse ID> <Velocity Scaling ID> <value>
xinput --set-prop 8 230 20.0

This has doubled the speed of the mouse pointer from 10.0 to 20.0

Experiment with different values until it's right for you. The higher it is, the more DPI you should cover.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.