2

I am trying to secure my xRDP with an free Let's Encrypt SSL certification.

xRDP is working but get an warning Untrusted Connection.

I have configured the following files:

 /etc/xrdp/xrdp.ini

Added the following lines under global:

certificate=/etc/letsencrypt/live/example.com/cert.pem
key_file=/etc/letsencrypt/live/example.com/privkey.pem
security_layer=tls

Update:

I think that i need an Network Level Authentication. But I can not confirm nor deny it.

Update 2:

Problem is solved about checking the version. Debian 8 repository is installing xrdp 0.6x and the current version of xrdp is 0.9x. Problem was resolved after removing the old xrdp version and installing a new version downloaded and compiled via their Github page.

PS. Check the XRDP version if you ran into any issue.

  • Do you have a message that says why the connection is untrusted? Can you display the certificate when connecting and verify that it is your Let's Encrypt certificate? – RalfFriedl Aug 26 '18 at 7:24
  • @RalfFriedl If i try to connect to an Windows server i get an warning about verify certificate. But if i try to login with xrdp to an Linux server i get not the same warning just the warning "untrusted connection". It seems like that the lets encrypt cert is not working, – Noob Aug 26 '18 at 14:17
  • It is both about no proper certificate. So is there an option in either of them to view the certificate? What address do you use in the client to connect to the RDP server? – RalfFriedl Aug 27 '18 at 5:36
  • 1
    @RalfFriedl problem solved. see my update above. – Noob Aug 27 '18 at 9:24
  • 1
    @Noob Welcome , It will be more helpful if you post an answer and accept it. – GAD3R Aug 28 '18 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.