1

The System

This is a brand-new ASUS Zenbook UX430UAR dual booting the pre-installed Windows 10 and a minimal Debian, uname -a:

Linux myhostname 4.9.0-7-amd64 #1 SMP Debian 4.9.110-3+deb9u2 (2018-08-13) x86_64 GNU/Linux

The Problem

When the touchpad (motion and tap) has been idle for about one second (definitely less than two), the next tap is ignored. The motion response also lags noticeably after being idle, and it seems that the longer I am idle, the more pronounced it is. The motion lag disappears after a moment of use.

Why It's A Problem

This is a bad situation because in order to safely execute a single click by tapping, you must wait at least one second, then double-tap. You can't just double-tap as a rule, since if there was a motion event within one second of the double-tap, it will be registered as two clicks.

Or you could just single tap as a rule, and hope for visual feedback to tell you whether the tap worked or not. If it takes you more than one second to evaluate the visual feedback, the cycle will be repeated!

What I've Tried

  • I've scoured about two dozen pages for ideas
  • "libinput Disable While Typing Enabled" was 1 by default, but I have set it 0 via xorg.conf.d and the setting does persist across reboots
  • I tried various things to disable USB autosuspend, including disabling autosuspend on all devices using the "usbcore.autosuspend=-1" and/or "usbcore.autosuspend_delay_ms" kernel boot options -- these seem to take effect, to judge by the /sys/bus/usb/devices/*/power/autosuspend files, after rebooting. (I've removed the boot option now.)
  • I ensured that none of the following are installed, since they are known to interfere with manual power management configuration: laptop-mode, powertop, pm-utils, tlp
  • I tried installing the xserver-xorg-input-synaptics but libinput continued to be used (and I dare not remove libinput lest I be left without a keyboard)
  • I tried two different window managers (my own hack of twm that I normally use, as well as stock fluxbox)

Unfortunately nothing I've tried has influenced this touchpad misbehaviour in any perceptible way.

Is there some device file I could echo to in a once-per-second loop to keep the touchpad from being idle, yet without triggering actual events on the desktop? (This is probably what I'll try next, as I await answers or comments.)

Can anyone suggest something else to test or try, so that the touchpad is as responsive after being idle as it is in the heat of action? These are popular notebooks and a pretty good value, so a solution to this stands to benefit many.

  • 1
    synaptics won't do anything unless you enable it. The keyboard should not get disabled if you switch to it. – Mioriin Aug 25 '18 at 19:29
  • Thank you Mioriin, I reinstalled synaptics and changed my config file in /etc/X11/xorg.conf.d and my problem is solved. If you would like to make an answer of it I can accept it. So much pain and it was quite simple; I guess I'll try libinput again in a while to see if the problem is gone. – flaysomerages Aug 25 '18 at 21:16
  • Sorry I spoke too soon. What you suggested was true, and I've now confirmed that synaptics is driving the Elantech touchpad. But, the problem persists... – flaysomerages Aug 25 '18 at 21:19
  • I've tried using xinput in a loop (every 0.5 seconds). First I tried setting the button mapping (to the same value it had). Then I tried enable. And finally I tried disable/enable pairs. The latter quite naturally wreaks havoc on the usability, but alas even that does not solve the problem. I also noticed that xinput --test reports no event for the failed clicks (but does report the second, working click). – flaysomerages Aug 25 '18 at 21:53
  • Using a USB mouse, I've noticed that if I move with the mouse, then (quickly) tap the touchpad, the click works. So it seems I should be able to get a workaround using XTEST or so. If I have any luck I'll make another comment. Hopefully I can do it without actually moving the cursor! – flaysomerages Aug 25 '18 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.