0

When I run the command

$ man ls

all it shows me is

Manual page ls(1) line ?/? (END) (press h for help or q to quit)

and after pressing q

man: command exited with status 4: (cd /usr/share/man && /usr/lib/man-db/zsoelim) | (cd /usr/share/man && /usr/lib/man-db/manconv -f UTF-8:ISO-8859-1 -t UTF-8//IGNORE) | (cd /usr/share/man && preconv -e UTF-8) | (cd /usr/share/man && tbl) | (cd /usr/share/man && nroff -mandoc -rLL=204n -rLT=204n -Tutf8)

Has anyone experienced the same issue? How to fix it?

0

Not sure how it was related to the problem, but the answer below helped me:

https://askubuntu.com/a/763984/572615

I had to execute the suggested commands:

sudo apt-get purge grub\*
sudo apt-get install grub-efi
sudo apt-get autoremove
sudo update-grub
  • I can't see how reinstalling the bootloader can fix the manpage database. I think it's more likely that the system was updating the manpage database in the background while you were accessing it, making the output garbled. – Mioriin Aug 25 '18 at 16:16
  • @Mioriin It is unlikely. I've tried to view man pages at different times with the same result. – ka3ak Aug 25 '18 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.