I tried to change my /home username so I switch to tty0 and change the username by usermod command but because some pid is active , I can't modify user. So I kill those proccess with kill command. After this I reboot my machine. Now for booting my machine, /home partition (XFS type) failed mount. So try fix that with

$ sudo xfs_repair /dev/sda5
print_req_error: IO error dev sda sector 1070323416
xfs_repair : Read failed input/output error
the log head and/or tail cannot discovered


$sudo xfs_repair -L  /dev/sda5
print_req_error: IO error dev sda sector 1070323416
xfs_repair: Read failed: Input/output error
zero_log cannot find log head_tail (xlog_find_tail=-5)

How can I resolve this to boot my machine correctly without lose of any data from the corrupted partition?

  • 1
    So from that I understand, you were able to get at least to single user mode. The usermod is unlikely to cause partition corruption by itself, there was probably some problem caused by something else. Please provide us outputs of lsblk and fdisk -l. Also check logs for related messages. – Jaroslav Kucera Aug 25 '18 at 6:47
  • I run those and provide output below – Navid Ahrary Aug 25 '18 at 13:00

As far as I see, this looks like a problem with your disk, hence the I/O error.

If the partition is not too big, I would try copying it to a blank HDD with a rescue program like ddrescue and then try to repair it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.