-1

Whenever I do "sudo apt update" I am getting eventually:

W: Failed to fetch http://ppa.launchpad.net/developmentseed/mapbox/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

What I have tried:



  • run sudo add-apt-repository --remove ppa:developmentseed/mapbox
    running this command I am asked are you sure you want to remove this? Of course the answer is yes
  • run sudo apt update and get the same initial error

So how on earth to get rid of this error?

Additional Notes:

  • 1
    Welcome. Please add the output of grep ^ /etc/apt/sources.list.d/* – GAD3R Aug 24 '18 at 19:37
  • 1
    I have updated the question with the answer at the "Additional Notes" section. – Cristian Aug 24 '18 at 19:43
  • Ppas are meant for ubuntu and rarely work well with Debian, so trying to add that repo was more or less asking for trouble. I assume you also made sure no other file in /etc/apt/sources.list.d contained a reference to this repo? I find it hard to believe that a file appeared in /etc/apt/sources.list.d as a result of running apt update, can you provide output proving that? – Henrik Aug 24 '18 at 19:44
  • 1
    Did you need to install tilemill? – GAD3R Aug 24 '18 at 20:04
  • 1
    Yes, this is the root of the situation. – Cristian Aug 24 '18 at 20:09
2

The url isn't valid.

The possible codenames for the ppa:developmentseed/mapbox can be found here

To solve the problem you should manually remove the file under /etc/apt/sources.list.d

# rm /etc/apt/sources.list.d/*
# apt update

To install tilemill , install nodejs then follow the installation guide.

$ sudo apt install build-essential git curl
$ curl -sL https://deb.nodesource.com/setup_6.x -o nodesource_setup.sh
$ sudo bash nodesource_setup.sh
$ sudo apt-get install -y nodejs
$ git clone https://github.com/tilemill-project/tilemill.git
$ cd tilemill
$ npm install
$ npm install sqlite3
$ ./index.js --server=true

Then type localhost:20009 in your web browser.

  • 1
    Beware: This removes all additional repositories. – Hermann Aug 24 '18 at 20:01
  • 1
    @Hermann Right , but in this case, there is only one file (see the output of grep ^ ...) – GAD3R Aug 24 '18 at 20:03
  • 1
    Suddenly it just worked with what you've answered. This is very awkward. Now the file did not appear again after removing it and running apt update. I've already tried this many times as written in the question. – Cristian Aug 24 '18 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.