0

In Evolution I set up a second account which only sends email, to create a alias using the GMail "+" trick. That is, my main Evolution account is something like john.doe@gmail.com and the alias account is like john.doe+FOOBAR@gmail.com. Upon creating the alias account Evolution sent me to GMail to log in for an OAuth token, I tested the account and it worked just fine.

However, now that I've logged out of my desktop and back in again, every attempt to send from the alias account gets the error. The full error from the log journal is:

evolution-sourc[2880]: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.734 was not provided by any .service files

I can send emails just fine with my original/default Evolution account.

I'm using Fedora 28 and KDE.

EDIT: Looks like it might be due to this gnome keyring bug. Unfortunately there's no suggested workarounds. I tried replacing the gnome keyring daemon with gnome-keyring-daemon --replace --blah --blah, but that didn't help.

0

Looks like the problem is that some user session daemon isn't quitting when the session is over. Since I use SDDM I fixed the problem by editing /etc/sddm/Xstop to run the following command when the X server stops:

killall -9 -u user dbus-daemon gnome-keyring-daemon evolution-source-registry \
    evolution-calendar-factory-subprocess evolution-addressbook-factory \
    evolution-addressbook-factory-subprocess at-spi2-registryd \
    at-spi-bus-launcher

I'm not sure which of the processes is responsible, since all of them still exist when Xstop runs. If I narrow things down I'll update this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.