I am setting up a computing cluster, and have been tasked with setting up a NIS server and client environment. So far I have been successful on every front except for the NIS clients are not mounting the home directory.

I have been following the steps in this article, which has gotten me thus far. I am able to login to the NIS client properly, but when it gets there it throws me to a bash prompt and says Could not chdir to home directory /nethome/cfduser: No such file or directory. When I get to the bash prompt I can confirm that that /nethome directory is there, but it is empty.

I am not sure where to go from here. I can supply whatever configuration files are needed and more if needed.

Both the client and server are running CentOS 7 b1804

Edit 1:

My /etc/auto.master

# Sample auto.master file
# This is a 'master' automounter map and it has the following format:
# mount-point [map-type[,format]:]map [options]
# For details of the format look at auto.master(5).
/misc   /etc/auto.misc
# NOTE: mounts done from a hosts map will be mounted with the
#       "nosuid" and "nodev" options unless the "suid" and "dev"
#       options are explicitly given.
/net    -hosts
# Include /etc/auto.master.d/*.autofs
# The included files must conform to the format of this file.
# Include central master map if it can be found using
# nsswitch sources.
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.

/nethome      /etc/auto.home

My /etc/auto.home

* -rw,sync
  • What's the output of ypmatch cfduser auto.home? Have you checked in the messages log for failed mount attempts? Can you mount "by hand" successfully (mount -o rw,sync /mnt/tmp_mnt)? – BowlOfRed Aug 23 '18 at 20:04
  • @BowlOfRed I was able to manually mount the folder to the correct location and then I could login with the correct prompt, but it is read only now. – hightekjonathan Aug 23 '18 at 20:05
  • @BowlOfRed I get this as my result of ypmatch Can't match key cfduser in map auto.home. Reason: No such key in map – hightekjonathan Aug 23 '18 at 20:12
  • @BowlOfRed with the explicit mapping, ypmatch still shows no key match, and the dir still isn't being synced – hightekjonathan Aug 23 '18 at 20:43
  • @BowlOfRed ypcat -k auto.master -> No such map auto.master. Reason: No such map in server's domain and ypcat -k auto.home -> cfduser -rw,sync Does this mean I have a misconfiguration with my auto.master file? – hightekjonathan Aug 23 '18 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.