0

My system (Centos7) install of curl doesn't support https. So I followed this answer downloaded from source and installed myself, using the ./configure --with-ssl option.

I got the following warning while configuring:

checking OpenSSL linking with -ldl... no
checking OpenSSL linking with -ldl and -lpthread... no
checking for ssl_version in -laxtls... no
configure: WARNING: SSL disabled, you will not be able to use HTTPS, FTPS, NTLM and more.
configure: WARNING: Use --with-ssl, --with-gnutls, --with-polarssl, --with-cyassl, --with-nss, --with-axtls, --with-winssl, or --with-darwinssl to address this.

As a result, my curl build does not support https.

Open SSL is installed on my system:

[user@server curl-7.61.0]$ which openssl
/usr/bin/openssl

How can I get my curl install to find openssl and support HTTPS?

4
  • Why do you think it doesn't support https? The standard CentOS 7 curl package does support https and /usr/bin/curl is linked with libssl.so
    – doneal24
    Aug 23, 2018 at 15:08
  • @DougO'Neal When i did curl -V is didn't list https as supported. More precisely, git won't push or pull because Protocol https not supported or disabled in libcurl
    – kingledion
    Aug 23, 2018 at 15:10
  • First, curl and libcurl are separate packages. Second, the CentOS libcurl is also linked with libssl3.so. curl -V should return curl 7.29.0 (x86_64-redhat-linux-gnu) libcurl/7.29.0 NSS/3.28.4 zlib/1.2.7 libidn/1.28 libssh2/1.4.3 along with Protocols and Features that include https and SSL. can you provide the output of which curl and locate libcurl?
    – doneal24
    Aug 23, 2018 at 15:18
  • So I have two curls on the system now, one at /usr/bin/ and one at /usr/local/bin, and there are libcurl.so files for each. I think I have this solved, I just need to get down to only one curl on the system.
    – kingledion
    Aug 23, 2018 at 15:39

1 Answer 1

1

To satisfy the configure script and have your compiled curl support OpenSSL, you'll need to install the corresponding development package, openssl-devel.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .