0

I installed Ubuntu on a PC that had another Linux distribution already installed. When installing Ubuntu, I chose to delete all data that was written before in the disk, so it probably deleted the other distribution.

The problem is that when I restarted the computer the grub screen appeared, wich states that it was unable to load Ubuntu's kernel:

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device of file completions.

grub>

I used grub>ls to have an idea of what I could load from here and got this:

(lvm/ubuntu--vg-swap_1) (lvm/ubuntu--vg-root) (hd0) (hd0,gpt2) (hd0,gpt1)

I used ls on each of them to check wich one was the actual filesystem and (hd0,gpt1) was the only one who didn't throw error: unknown filesystem.

I tried doing what this tuto says https://xuri.me/2013/09/03/resolve-ubuntu-error-unknown-filesystem-grub-rescue.html but it still doesn't work.

The file tree of (hd0,gpt1) looks like this:

hd0,gpt1/
----efi/
--------ubuntu/
------------fw/
------------fwpx64.efi
------------grub.cfg
------------shimx64.efi
------------mx64.efi
------------bootx64.csv
--------boot/
------------bootx64.efi
------------fbx64.efi
0

you can try to boot with the installation media that you used previously, into rescue mode, and issue the last 2 commands from the tutorial:

$ sudo update-grub

$ sudo grub-install /dev/sda

  • Yes, I think there was a problem at the time I first installed Ubuntu. I installed it again with the installation media and it hasn't given me any problems at all. Thank you! – Rodrigo Barrios Aug 24 '18 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.