1

I have a bootable persistent usb kali. I need to add a "nouveau.modeset=0" to my grub boot parameters. I can do this temporarily by pressing 'e' on the GRUB menu and putting it in there like this answer says, but I can't do the permanent solution there since /etc/default/grub doesn't exist (I'm assuming because grub is installed at another location or it's set to look somewhere else for it's parameters). Does any one know if I can just create the file, or is it stored somewhere else?

 root@kali:~# df -h
 Filesystem      Size  Used Avail Use% Mounted on
 udev            7.8G     0  7.8G   0% /dev
 tmpfs           1.6G  9.8M  1.6G   1% /run
 /dev/sda1        30G  2.9G   27G  10% /lib/live/mount/persistence/sda1
 /dev/loop0      2.5G  2.5G     0 100% /lib/live/mount/rootfs/filesystem.squashfs
 tmpfs           7.8G     0  7.8G   0% /lib/live/mount/overlay
 /dev/sda2        29G  107M   28G   1% /lib/live/mount/persistence/sda2
 overlay          29G  107M   28G   1% /
 tmpfs           7.8G   99M  7.7G   2% /dev/shm
 tmpfs           5.0M     0  5.0M   0% /run/lock
 tmpfs           7.8G     0  7.8G   0% /sys/fs/cgroup
 tmpfs           7.8G     0  7.8G   0% /tmp
 tmpfs           1.6G   32K  1.6G   1% /run/user/0
 root@kali:~# sudo lsblk -m
 NAME          SIZE OWNER GROUP MODE
 loop0         2.5G root  disk  brw-rw----
 sda          58.8G root  disk  brw-rw----
 ├─sda1       29.4G root  disk  brw-rw----
 └─sda2       29.3G root  disk  brw-rw----
 nvme0n1       477G root  disk  brw-rw----
 ├─nvme0n1p1   499M root  disk  brw-rw----
 ├─nvme0n1p2   100M root  disk  brw-rw----
 ├─nvme0n1p3    16M root  disk  brw-rw----
 └─nvme0n1p4 476.3G root  disk  brw-rw----
 root@kali:~# sudo parted -ls
 Model: SanDisk Cruzer Fit (scsi)
 Disk /dev/sda: 63.1GB
 Sector size (logical/physical): 512B/512B
 Partition Table: msdos
 Disk Flags: 

 Number  Start   End     Size    Type     File system  Flags
  1      1049kB  31.6GB  31.6GB  primary  fat32        boot, lba
  2      31.6GB  63.1GB  31.5GB  primary  ext4


 Model: NVMe Device (nvme)
 Disk /dev/nvme0n1: 512GB
 Sector size (logical/physical): 512B/512B
 Partition Table: gpt
 Disk Flags: 

 Number  Start   End    Size    File system  Name                          Flags
  1      1049kB  524MB  523MB   ntfs         Basic data partition          hidden, diag
  2      524MB   629MB  105MB   fat32        EFI system partition          boot, esp
  3      629MB   646MB  16.8MB               Microsoft reserved partition  msftres
  4      646MB   512GB  511GB   ntfs         Basic data partition          msftdata


 root@kali:~# sudo find / -name grub.gfg
 ^C
 root@kali:~# sudo find / -name grub.cfg
 /lib/live/mount/persistence/sda1/boot/grub/grub.cfg
 /lib/live/mount/persistence/sda1/boot/grub/i386-efi/grub.cfg
 /lib/live/mount/persistence/sda1/boot/grub/x86_64-efi/grub.cfg

Edit: This is been solved thanks to @sudodos. I know this community can be very uptight sometimes, and a lot of people on here can be snobby (namely the 5 people that marked this as duplicate with "Why is Kali linux so hard?"), but people like @sudodos are what keeps stack exchange awesome.

5
  • 1. Please tell us which tool you used to create the persistent usb kali system; 2. Run the following commands and edit your original question to show the output of the commands. Indent each line 4 spaces to render the output as 'code'. df -h and sudo lsblk -f and sudo lsblk -m and sudo parted -ls and sudo find / -name grub.cfg; This will help us help you. – sudodus Aug 22 '18 at 6:32
  • If the persistent image is an ISO image, it is far too complicated to be worth it. – Rui F Ribeiro Aug 22 '18 at 8:57
  • If you use mkusb to create a persistent live drive, I can help you locate the active grub.cfg file and also help you edit it. – sudodus Aug 22 '18 at 13:08
  • 1
    @sudodus Thank you I fixed it thanks to you. I just needed to find the grub.cfg file. If you post as an answer I will accept it – Mauricio Martinez Aug 22 '18 at 15:55
  • I'm glad that I could help you find the grub.cfg file, and that you could solve the problem :-) But I cannot post an answer because the question is marked as a duplicate. – sudodus Aug 22 '18 at 17:41