1

I have gone through a lot of questions and answers related to grub rescue but I am having a different problem which I am not able to understand.

As per some of the answers, I tried following steps to resolve this problem -

  1. First of all I used ls command to get all the partitions which in my case were (hd0), (hd0,msdos5), (hdo,msdos1), (hd1) & (hd1,msdos1)

  2. Out of the above 5 partitions, I got Filesystem is ext2 message for (hd0,msdos1) drive.

  3. As per some of the answers provided in ask ubuntu & stack exchange I tried to set the root & prefix using (hd0,msdos1) drive (which I found using ls command)

  4. While setting prefix I realised that the /boot/grub directory does not exist in selected drive (hd0,msdos1).

  5. As a result of this when I try to fire insmod normal command, grub rescue gives an error saying /boot/grub/i386-pc/normal.mod not found

  6. Apart from this, I tried using bootable USB drive with ubuntu 14, 16, 17, 18 & even windows OS but I always ended up in grub rescue window.

This leaves me with following questions -

  1. Am I setting a wrong drive as root drive (provided this is the only ext2 drive among 5 enlisted drives) ?

  2. Is there a way of including the /boot/grub folder in the root directory so that I can run `insmod normal command ?

1

As the boot partition is mounted on on top of /boot once the system boots, you wont find there /boot/grub.

The directory you are searching is /grub in the boot partition.

As for mounting a full system, you will have to mount the / first, then /boot on top of it.

Actually, if you are in a live DVD of the same architecture, you often mount:

/mnt -> root partition
/mnt/boot -> boot partition
/mnt/proc /proc
/mnt/sys /sys
/mnt/dev /dev

And then do a chroot /mnt

As for loading kernel modules, I would load them from the live booting system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.