1

I'm working with the DataDomain server in our Commvault solutions. Anytime this server is rebooted the network disk in use for the solution does not remount. Right now this means we need to stop some processes then run:

boostfs mount -d datastore.company.com -s Commvault /cvdisk

I didn't see a way to mount with fstab so I tried following a guide to run scripts at boot. Now I have two scripts. The first:

cat /etc/systemd/system/remountboostfs.service
[Unit]
Description=Remount boostfs commvault drive
After=network.target

[Service]
Type=simple
ExecStart=/usr/local/sbin/cvdiskmount.sh
RemainAfterExit=yes

[Install]
Wantedby=default.target

That calls the second which should handle the mounting

cat /usr/local/sbin/cvdiskmount.sh
#!/bin/bash

(cd /opt/emc/boostfs/bin && ./boostfs mount -d datastore.company.com -s Commvault /cvdisk)

After some trial and error I can confirm that the second script will remount the drive when run manual, and that the first service file is running (not not generating anything in the messages logs (not since I fixt the counting script).

Is there a better way to remount this file system on rebooting? What am I missing in the current scripts?

Edit 1: As seen in the notes the fstab works as written:

aemb01p.salemstate.edu:Commvault /cvdisk boostfs defaults 0 0

This works perfectly, but when I tried to convert this for automount/ autofs this doesn't appear to work. No errors, notices or logs I can find.

$cat /etc/auto.master| grep cvdisk
/cvdisk   /etc/auto.cvdisk --timeout 120

$cat /etc/auto.cvdisk
/  -fstype=boostfs aemb01p.salemstate.edu:Commvault
  • I've removed the CentOS and RHEL tags, as it appears from some searches that DataDomain OS is a proprietary OS (perhaps based on a Linux, perhaps not). – Jeff Schaller Aug 25 '18 at 20:29
0

See page 37 of the BoostFS for Linux Configuration Guide. In there, you will see a section on using mount. For your environment, the mount command would be mount -t boostfs datastore.company.com:Commvault /cvdisk. In /etc/fstab terms:

datastore.company.com:Commvault /cvdisk boostfs defaults 0 0
  • 1
    Oddly the location didn't mount on my last reboot, but it did after a mount -a. I'm running close to when the next backups will trigger, but I'll test again when it's safe, and try and rule out a one time fluke. Thank you for the useful documentation. – RunThor Aug 21 '18 at 20:33
  • It's entirely possible that the daemon wasn't started when fstab attempted the mount. There's an autofs solution documented in the linked guide - that may work better – Outurnate Aug 21 '18 at 20:39
  • 1
    I did some additional testing this morning and fstab appears to be working now. Thank you. – RunThor Sep 13 '18 at 19:16
  • Awesome! Is there something you did that's missing from my answer? I'd like to make sure it's complete for future visitors – Outurnate Sep 14 '18 at 16:40
  • 1
    Nope, it failed the first test. When I got the chance to retest it it mounted every time after that. I did mess around a little with the automount process but all that code is gone now and it still works. – RunThor Sep 17 '18 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.