1

Transmission seeder

Objective

The Transmission tool provided with my Linux doesn’t seeds the torrent automatically like bit Torrent does on Windows. I want it to start with my PC and start seeding without me having to launch the application and manually hit the start button on each torrent for it to seed. I need to set it up to work that way on Linux.

Motivation

Return the favor to the torrent community.

Ethics

Giving back, selflessness

Initial Hypothesis

I looked about it a while ago and I think I might need to download a Transmission Daemon and let it auto-start with my computer.

Updates

21/08/18

17:04:48 I need to get the daemon tool and the CLI to configure. It isn’t simply about setting it up. There are lots of things that can be done. I can control the torrent client from my phone. I can white or black list IP addresses. Its gonna be fun.

17:13:38 The daemon and CLI is already installed. I only need to configure it.

17:31:59 I am done configuring. The configuration was already done by me on the GUI application. That was all. All that I changed in it was adding my WiFi as an allowed client. I have added transmission-daemon to startup application. Let’s see how it work. Or if it does or not. I am currently upgrading my system so I cannot restart my system right now.

23:45:24 I did restarted the system but I couldn’t make the daemon start by adding the transmission-daemon command in the startup applications list. I need to duck duck go it.

22/08/18

19:26:56 I posted a question on Stack Exchange. A guy answered that I might use qbittorrent instead. I download it just now. Lets see if that works.

19:37:46 It does starts mimimized and starts seeding on its own. I only need to make sure it does the same when the system starts. It also seems to have features like managing seperately the torrent files for completed and incomplete state and automatically adding from the chosen folder.

19:41:43 I confirmed the correct steps for adding apps to startup from the official documentation. I’m going to try it out right now.

19:49:04 It did work. qbittorrent started automatically and started seeding. Even though the objective says “I need to set it up to work that way on linux.”, where “it” was transmission but the ignoring the words and looking at the real motive, my seeding is working on it own.

19:55:29 I configured it to start minimized and to show the icon which was only for test. Next I am going to turn the icon off. That will be the final icing.

Conclusion

I wasn’t able to configure transmission to work my way and the credit goes to my lack of Linux experience, still my job is done. qbittorrent works. I downloaded it. Gave it the torrent files and the download folder. It mapped, checked and started seeding the torrent pretty easily. Then I added qbittorrent in the startup application’s list. That did the magic.

0

Using startup applications (default program installed in linux) you can set transmission to start when you start the pc.

You can do the same with qBittorent which you won' t regret to try, it will start automatically to seed the torrents and it has many features.
Quick instructions for ubuntu:

To use these PPAs please use the following command and make sure your version is supported:

qBittorrent Stable

sudo add-apt-repository ppa:qbittorrent-team/qbittorrent-stable

or qBittorrent Unstable

sudo add-apt-repository ppa:qbittorrent-team/qbittorrent-unstable

Then install qBittorrent by doing this:

sudo apt-get update && sudo apt-get install qbittorrent 

When using startup applications in the Command field write:
qBittorent

0

Put the daemon in crontab:

(crontab -l;echo "@reboot transmission-daemon") | crontab
  • Doesnt it fail in case of cold boot? – vfbsilva Aug 21 '18 at 18:46
0

I believe you might better:

 service enable transmission-daemon

This will make systemd create a init service for you.

Addendum, okay so ubuntu has some fixing that must be done: Create this file:

/etc/systemd/system/transmission-daemon.service.d/override.conf

with this content:

[Service]
User=
Type=
Type=simple
User=debian-transmission
Group=debian-transmission

then you must execute this in order to reload systemd config:

$systemctl daemon-reload

and finally you must execute:

$systemctl start transmission-daemon.service

And then finally service enable transmission-daemon

Source

  • user@machine:~$ service transmission-daemon enable * Usage: /etc/init.d/transmission-daemon {start|stop|reload|force-reload|restart|status}' – Lenovo320 Aug 21 '18 at 19:00
  • 1
    This was returned – Lenovo320 Aug 21 '18 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.