1

https://imgur.com/a/caCiVueCan't mount Root FS I have GParted setup almost identically to as described in the website help:

https://gparted.org/livepxe.php

The only difference between that the root directory is not / rather /GParted

The vmlinuz and initrd seem to boot ok. The filesystem.squashfs is loaded via http and I can successfully wget it.

However, when it try to mount of the filesystem.squashfs, I have a problem as shown in the red box.

Mounting root file system ... /init: .: line 225: can't open '/scripts/GParted/live'

I'm not sure where /scripts/GParted/live is. I'm also not sure how it would get a directory in front of my root /GParted However, the system manages to find /scripts/init-premount

My PXE default here:

LABEL GParted Live
MENU LABEL GParted Live
kernel GParted/live/vmlinuz
APPEND initrd=GParted/live/initrd.img boot=GParted/live config components union=overlay username=user noswap noeject ip= vga=788 fetch=http://10.1.200.1/GParted/live/filesystem.squashfs
ENDTEXT

Where have I gone astray?

0

The /scripts/init-premount lives inside the GParted initrd.img file.

The error message suggests the system is running into trouble on line 225 of script /init within the initrd image.

The line 225 of that script is:

. /scripts/${BOOT}

And the ${BOOT} variable gets its value from the boot= boot parameter earlier.

So, the mistake is in assuming that if you put the filesystem.squashfs file into a sub-directory on the web server, you need to adjust the value of the boot= option to match. That is incorrect.

The boot= option specifies the boot mode: local, nfs, or live. This causes the script system (= initramfs-tools from Debian) to run the corresponding script in the /scripts/ directory. /scripts/live exists in the initrd.img file, but /scripts/GParted/live doesn't.

So, change the APPEND line of your PXE bootloader configuration to:

APPEND initrd=GParted/live/initrd.img boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=http://10.1.200.1/GParted/live/filesystem.squashfs

...and then it should work.

0

That was it. I didn't realize the boot= was a parameter as opposed to the initial boot directory holding initrd. Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.