After looking for a solution for quite some time, I came here to ask. My problem is as follows. Most software can't play any sound. However, there are exceptions, Chrome and Discord can play audio for some reason. I tried to manipulate my .asoundrc file and created it with the following contents:

defaults.ctl.card 1
defaults.pcm.card 1
defaults.pcm.device 3
defaults.timer.card 1

ctl.!default {
    type hw
    card 1

pcm.!default "plughw:1,3"

pcm.clone "plughw:1,3"

This didn't solve the problem. The clone alias was created for testing purposes and yields (for me) uncomprehensible results:

  • aplay -D clone file.wav plays the specified file as expected,
  • aplay -D plughw:1,3 file.wav plays the file as expected,
  • aplay -D default file.wav fails to produce any sound (although the console output is the same as when running the commands above),
  • aplay file.wav fails to produce any sound.

I tried relogging and rebooting, nothing changed. Alsamixer functions as usual.

  • It appears some other configuration file manages to override your default device (check /etc/asound.conf). Anyway, PulseAudio ignores all that completely. – CL. Aug 21 '18 at 18:07
  • There isn't any file at /etc/asound.conf. I don't know much about how PulseAudio works, but still I'm convinced at least aplay -D default ... should function properly. – Mimarik Aug 21 '18 at 18:11
  • I managed to solve this problem by installing pavucontrol and manipulating the settings there - aplay now plays sound as it should. I will test other software now. – Mimarik Aug 21 '18 at 19:30

Finally, I managed to solve my problems. I needed to install pavucontrol, add the correct device to PulseAudio's list of available sinks, then set the newly added sink (generated from an ALSA device) as the default one for PulseAudio. That fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.