1

Building latest syslog-ng (3.17.2, rather than the packaged version in EPEL, which is 3.5.6, built 30-Dec-2015) from https://github.com/balabit/syslog-ng/releases

Amidst ./configure --prefix=/app/syslog-ng, it gives error:

configure: error: Cannot find OpenSSL libraries with version >= 0.9.8 it is a hard dependency from syslog-ng 3.7 onwards


# yum install openssl
Loaded plugins: package_upload, product-id, search-disabled-repos, subscription-manager 

  .......

Package 1:openssl-1.0.2k-8.el7.x86_64 already installed and latest version

# openssl version
OpenSSL 1.0.2k-fips  26 Jan 2017
# rpm -qa|grep -i openssl
pyOpenSSL-0.13.1-3.el7.x86_64
openssl-libs-1.0.2k-8.el7.i686
openssl-1.0.2k-8.el7.x86_64
openssl-libs-1.0.2k-8.el7.x86_64
# cat /etc/system-release
Red Hat Enterprise Linux Server release 7.4 (Maipo)
#

How do I resolve this config error?

1

configure is looking for the relevant openssl development files and cannot find them. On your RHEL 7 system, easiest way to achieve this is to yum install openssl-devel and then retry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.