1

In some applications (some) menus are invisible on my Linux Mint 18.3 KDE-edition.

For example in Firefox the dropdown menu of my plugins or the one showing recent downloads (top right corner) are invisble. The icons themselves are visible but when clicking on the icon nothing seems to happen (whereas normally a dropdown menu would appear). If I click at the location such a dropdown menu entry normally is be located, I still get the normal behavior (e.g. in the downloads-dropdown this will open the file manager showing me the repspective file). I am therefore deducing that the menu is still there but isn't getting rendered for some reason. The normal menu is working normally though and the context menu inside Firefox is also working just fine.

Another example I am experiencing this kind of behavior is Okular in which the normal menu (top of the window) is not being rendered if clicked upon. I can see the menu entries (File, Edit, View, etc.) at the top of the window but no dropdown is shown when clicking on them. The functionality of the menu is present though (e.g. clicking in "empty space" opens the dialog for opening files, etc.) so yet again the dropdowns simply aren't rendered. Furthermore the context menu isn't shown at all. I haven't been able to access the invisible dropdown's functionality because I don't know by heart where the respective entries are located. It does take the mouse focus though (If right-clicking in the document I can't select anything else with the first mouse-click as if that click would close the invisible dropdown first).

The last application I experienced this phenomenon is LibreOffice where the icon stating that there is a new version available is invisible. The speech bubble stating the message is visible though which is why I even noticed that that button isn't being rendered. (The invisible button's frame is rendered if hovering the mouse over it)

Has anyone came across such behavior before and/or has a clue on how this could be fixed? If you need any further information just go ahead and ask for it - I'll be more than happy to provide it.

I have opened all those applications via terminal in order to see if there are any error messages shown but there aren't.
These problems seem to have started after I have fiddled with the locale settings on my machine - not sure if there is any connection though.

EDIT: In order to clarify what I am trying to say I'll provide some pictures:
enter image description here Right here you can see the dropdown menu of "recent downloads" button in firefox. The button itself (the downwards pointing arrow) is located in the top right toolbar and when clicking on it the shown dropdown opens showing the most recently downloaded files. If one clicks on one of these files, the file-explorer will open to that file's location.
Now to my problem: I see the very same icon in my firefox's toolbar but when I click on it, it seems as if nothing happened. Except that the button takes the same shape as it does when the dropdown menu has been opened and when I click at the position the first menu entry would normally be, my file-explorer opens and shows me my last download. Therefore the dropdown must indeed have opened but either it isn't rendered or it is rendered completely transparent.

Image of okular menu Next up you can see the normal dropdown menu of okular (I am talking about the File-menu in this case). Notice that the Button saying File at the top of the window has its characteristic borders because it is currently active. Furthermore notice that the first menu entry is the Open... action.
On my machine I can see all those menu entries at the top of the window and if I click on File the button takes its "activated shape" as can bee seen in the provided image. Unlike in the provided image I will not see anything of the dropdown menu but if I click at the position the Open File entry is located in the image, the corresponding dialog opens that lets me choose a file to open. Therefore the dropdown must be present but either not being rendered or completely transparent.

enter image description here In this image one can see the context menu in okular that appears after having selected some area. If clicking somewhere else in the application nothing happens except that the context menu closes after having lost focus.
This context menu doesn't show up on my machine but I still need two clicks in order to select something else in the application. This indicates that once again the menu is being created but is invisible.

I hope I could make clear, what my problem is. If not I will try to rephrase it once more.

closed as unclear what you're asking by Rui F Ribeiro, msp9011, Isaac, slm Aug 21 '18 at 5:20

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Could someone please explain why this question is put on hold? I described my problem and I am asking if anyone knows how to solve it? What part of that is unclear? – Raven Aug 21 '18 at 12:41
  • They don't understand it. Make it more clear and concentrated, then ping me for a reopen vote. – peterh Aug 21 '18 at 13:08
  • @peterh I added some pictures and further explanation. I hope it is more clear now. – Raven Aug 21 '18 at 14:36
  • 1
    Ok, I voted to reopen. I was the first. You need yet 4. – peterh Aug 21 '18 at 15:37
  • Alright there has been an update to the Xorg-Server and now those menus are visible again. Therefore the issue has been solved. – Raven Aug 23 '18 at 6:37