0

I'm running the following setup: beaglebone black [wireless version - 4.9.82-ti-r102 #1 SMP PREEMPT] -- running debian 9.3 stretch.

I've attempted to install the latest postfix mail server -- just so I can read the debug messages from cron.

I notice that the mailque is full of emails to root@beaglebone.localdomain.

Yet, if I try to:

> sudo mail

I get :

no mail for root

Question: What should my root email address be ? Obviously not root@beaglebone.localdomain!

Is there something wrong with either my postfix conf or the contab?

My /etc/postfix/main.cf looks like this:

# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
myorigin = localhost
mydestination = $myhostname, localhost.$mydomain, localhost
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
relayhost =

The root contrab looks like this:

MAILTO="root@beaglebone.localdomain"
SHELL=/bin/sh
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
# For example, you can run a backup of all your user accounts
# at 5 a.m every week with:
# 0 5 * * 1 tar -zcf /var/backups/home.tgz /home/
#
# For more information see the manual pages of crontab(5) and cron(8)
#
# m h  dom mon dow   command
5,35 * * * * cd /home/debian/bbbwifilogger/ && Rscript /home/debian/bbbwifilogger/graph.R &>/home/debian/bbbwifilogger/cron.log
6,36 * * * * cd /home/debian/bbbwifilogger/ && cp /home/debian/bbbwifilogger/moist.png /var/www/html/
6,36 * * * * cd /home/debian/bbbwifilogger/ && cp /home/debian/bbbwifilogger/tdegc.png /var/www/html/
7,37 * * * * cd /home/debian/bbbwifilogger/ && cp /home/debian/bbbwifilogger/dnlddata.zip /var/www/html/
3,33 * * * * /etc/init.d/networking restart
10,40 * * * * /usr/sbin/rtcwake -m mem -u -t $(date +%s -d "20 minutes") >> /home/debian/bbbwifilogger/bbblogger.log 2>&1

Thanks in advance for your advice.

0

To avoid mailbox full issue just increase email box size or rotate the mailbox.

/etc/postfix/main.cf:

message_size_limit = 31457280
  • Sorry Ebin, as indicated, I am trying to send the email to a local email address -- ie on the machine. The machine is not always connected to the internet. As you can see from the config files, I've attempted to configure this. You can also see that I have set the MAILTO in crontab. – userX Aug 20 '18 at 6:17
  • @user2449710 please see my update answer. – EBIN GLADSON Aug 20 '18 at 6:24
  • Hi Ebin, I don't think I have a mailbox full issue. It's just not being directed to the correct address. – userX Aug 21 '18 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.