I tried to make update on my system (4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:37:27 UTC 2018 i686 i686 i686 GNU/Linux ) via software updater but the update failed. So I tried to make the update via apt-get command but also not successfully. There was this output:

Do you want to continue? [Y/n] y Get:1 http://cz.archive.ubuntu.com/ubuntu bionic-updates/main i386 ubuntu-release-upgrader-gtk all 1:18.04.24 [9 360 B] Get:2 http://cz.archive.ubuntu.com/ubuntu bionic-updates/main i386 ubuntu-release-upgrader-core all 1:18.04.24 [24,3 kB] Get:3 http://cz.archive.ubuntu.com/ubuntu bionic-updates/main i386 python3-distupgrade all 1:18.04.24 [105 kB] Fetched 139 kB in 0s (881 kB/s) Extracting templates from packages: 100% Preconfiguring packages ... Setting up install-info (6.5.0.dfsg.1-2) ... /usr/sbin/update-info-dir: 3: /etc/environment: Syntax error: Unterminated quoted string dpkg: error processing package install-info (--configure): installed install-info package post-installation script subprocess returned error exit status 2 Errors were encountered while processing: install-info

What was wrong?

Thank you

  • Please post your terminal session as a code block, and describe what “failed” means. – G-Man Says 'Reinstate Monica' Aug 19 '18 at 20:44
  • Could you please edit your question and include the command you've executed? Also give the contents of your /etc/environment file using cat /etc/environment – Dipankar Nalui Aug 20 '18 at 6:07
  • From the output we understand that there is Syntax error in the file /etc/environment. – Dipankar Nalui Aug 20 '18 at 6:10

Check, if you have all needed folders in enviroment PATH like this:

# sudo echo $PATH

If not, you need correct this through adding appropriate folders to PATH variable.

Additionally check syntax at this file:

# sudo nano /etc/environment

All missing a " must be there.

  • Thank you, there was missing quotes in JAVA_HOME path in /etc/environment file. – Sir Montes Aug 25 '18 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.