0

Do I need the latest gcc? Can I use the gcc binaries included with my distro? Does it matter?

3

The kernel build requirements are quite conservative: for kernel 4.18, GCC 3.2 and binutils 2.20 are sufficient. Thus your distribution’s compiler should work fine.

In practice pretty much any version of GCC will do, although one can sometimes run into problems with versions of GCC which are too new. I’m currently using GCC 7 with no issues, but I haven’t tried GCC 8 yet to build the kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.