22

I have tried nvme_load=yes in place of quiet --- with Ubuntu 18.04.1 and Xubuntu 18.04. df -h results in only the system generated mounts and the installation media. The weekly live including firmware image of Debian also fails to discover the ssd.

I have located more information on the SSD. I found this information in the system profiler on OS X High Sierra.

Apple SSD Controller:
APPLE SSD AP1024M:
Capacity:   1 TB (1,000,555,581,440 bytes)
TRIM Support:   Yes
Model:  APPLE SSD AP1024M
Revision:   177.77.7
Serial Number:  C02829600M9JPD216
Link Width: x4
Link Speed: 8.0 GT/s
Detachable Drive:   No
BSD Name:   disk0
Partition Map Type: GPT (GUID Partition Table) . 
Removable Media:    No
S.M.A.R.T. status:  Verified 

lsblk from a xubuntu 18.04.1 live installer does not show any pcie or nvme devices.

Note: the installer and Gparted fail to list it. Typically these both require an unmounted drive to work with. So, it simply does not see the SSD. I read that this system uses a PCIE SSD , though im not sure how to send a kernel module to allow use of it.

  • Do the fail to discover it, or do they just fail to mount it? – RalfFriedl Aug 18 '18 at 21:48
  • Well, the installer and Gparted fail to list it. Typically these both require an unmounted drive to work with. So, it simply does not see the SSD. I read that this system uses a PCIE SSD , though im not sure how to send a kernel module to allow use of it. – Cheatcode Aug 18 '18 at 22:22
  • It is fairly know the latest Mac models are not compatible yet. – Rui F Ribeiro Aug 19 '18 at 13:52
  • This question is in a French newspaper: nextinpact.com/brief/… – Cœur Nov 7 '18 at 2:22
18

It's currently not possible to install anything except Windows 10 on Apple computers equipped with T2 chip. This security chip makes it impossible to see the internal drive, Apple generously did an exception only for Windows 10 (but only if you install it via Boot Camp). A possible option could be Linux installed on a USB/Thunderbolt external drive, unfortunately I tried this only for Windows but it worked (though the internal drive was not visible).

Update: changing the Secure Boot option makes no difference.

Update 2 (July 2019): custom patching of linux kernel seems to do the thing, unfortunately it's a pretty nerdy solution.

Source

  • 2
    Wow. Why the heck does turning off secure boot not fix the problem?! Apple says on their own site: "The 'No Security' setting doesn't enforce any of the above security requirements for your startup disk." Wat?! – Wowfunhappy Nov 6 '18 at 14:50
  • I don't know, but it's sadly true. – GeekUser Nov 9 '18 at 22:07
  • This is precisely the outcome that Linux users were decrying a few years back when Microsoft was starting to require secure boot. And now, Microsoft has done the right thing, but Apple is the one creating the exact dystopia that was predicted. How are they getting a pass on this? – thirtythreeforty Jun 19 at 14:44
  • 1
    Well, someone posted a patch that allows to see the SSD. The news article in turn refers to a big thread on github. You may want to update your answer on that. – Hi-Angel Jul 3 at 18:14
  • Thanks for the follow up, updated. – GeekUser Jul 11 at 18:33
14

I have a MacBook Pro Mid 2018 and managed to get the SSD working for like 10 seconds.

When you live boot Linux Mint or Ubuntu and do:

modprobe nvme

Then check for the hardware ID of the Apple Storage controller by doing:

lspci -nn | grep NVMe

Then put that ID in the new_id file under nvme:

echo 106b 2005 > /sys/bus/pci/drivers/nvme/new_id

When you did that it shows up under lsblk but only for like 10~30 seconds before the machine randomly turns off after 1second of full cooler spin 100%. I am not sure why this happens, but it does seem to detect it correctly as for me it showed a 500GB NVMe ssd under lsblk. I didn't manage to get gparted opened as it took longer than the time before it shuts off.

  • 7
    I'd be careful assuming this actually defeated the lock. Depending on how the T2 works it could be waiting for access then detecting an unauthorized access attempt and shutting down the system for protection. – madscientist159 Nov 5 '18 at 21:23
  • 2
    Please update your post if you had any more luck getting this to work. – Tom B Feb 11 at 15:53
  • @TomB still no solution to this issue :( I will post an update whenever I do have findings. – Menno van leeuwen Feb 14 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.