4

I am presently attempting to fix a broken (I think) Ubuntu 16.04 install on a VirtualBox install and it is hanging with the following message:

A start job is running for Create Volatile Files and Directories ( Xmin Ys / no limit)

I think I'm missing the broad picture here and am unsure where to start...

What is a "start job"? What is linux doing when the above message is emitted, and how do I find that out? Which processes and programs are at work? What should I read to get the high level picture here?

Note here is a collection of things that I have tried/am trying:

Login loop ubuntu 16.04 https://www.reddit.com/r/debian/comments/2jyquk/systemd_issue_at_boot_a_start_job_is_running_for/ https://www.youtube.com/watch?v=rvPtrwidhwo

2
  • 1
    Just move your mouse around and press some random keys during the whole boot process. 16.04 plus has some issues running single core in a VM during the installation process for me too. It's either processor starved or having to generate random data and doesn't have enough input. Aug 17, 2018 at 19:08
  • @RobotHumans appears to have worked now.. probably (I made a few changes from above links) due to your suggestion, thanks
    – Lee
    Aug 17, 2018 at 19:13

1 Answer 1

2

I ran into this same issue on a physical server. /tmp had 162,715 directories of tmp files, created by systemd. These directories were all dated and went back 2 years. I cleared them all out and system booted normally. Now, what I didn't check was whether the boot issue was because it was trying to traverse all the systemd-droppings, or if it's possible the filesystem was out of inodes. Either way, you shouldn't need the old tmp directories (d20171022-990-zxdejfd, for example) after a reboot, and you're save clearing them out. Not sure why systemd doesn't do this on its own.

3
  • Clearing up /tmp helps indeed. I was restarting an AWS EC2 instance and that was surprising... Fortunately you can re-attach the root volume to a different instance and do the cleanup.
    – Kuba
    Mar 22, 2019 at 11:40
  • 1
    How are you supposed to clear /tmp if you can't boot? Mounting the partition from a separate machine seems excessive?
    – Cerin
    Oct 10, 2019 at 2:00
  • 1
    You can boot in single user mode (add "single" to the end of the kernel line) and mount /tmp (hopefully it's its own partition), or boot off a rescue disk, or gparted, or PartedMagic, etc..
    – John L
    Oct 11, 2019 at 21:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .