1

I have a Xiaomi A1 with Android on it and I use my Samsung MicroSD Card Evo+ 129 GB, as as an internal storage. For no reason, it's stopped working and asking me to format it. The issue is, the device and even my laptop with Linux or Mac can't format it. I can't use it. I tried to do it with GParted (See screenshot below)

This is what I get when I run : sudo fdisk -l

    Disk /dev/sdc: 119,8 GiB, 128579534848 bytes, 251131904 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5875CF08-49DC-47BC-BEBF-A19D422163EA

Device     Start       End   Sectors   Size Type
/dev/sdc1   2048     34815     32768    16M unknown
/dev/sdc2  34816 251131870 251097055 119,7G unknown

Screenshot GParted about the SD Card

I tried to follow the path of this person but in vain : Decrypting Android M adopted storage

Any help would be very appreciated. Thank you for your time,

closed as too broad by Rui F Ribeiro, schily, Thomas, roaima, msp9011 Aug 17 '18 at 18:37

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm voting to close this question as off-topic because this isn't about UNIX or Linux – roaima Aug 17 '18 at 11:18