1

Okay, I have had this error for probably over 6 months and finally after being so lazy to do so am trying to get an answer to fix my problem. One day, doing absolutely nothing to screw up my Ubuntu, at least not intentionally, I get this error saying I have unmet dependencies and to run apt-get and to run package manager to see what's wrong. The thing is I cannot open terminal from my favorites or from the application menu but only if I right click on the desktop or inside the file manager will terminal open. Plus certain apps such as: gparted, software & updates, software updates and probably some other apps. When I try to sudo update, I get a series of errors and not found.

Here is what I get every time I login in and none of the options seems to do anything and just closes the error after I click either option.

enter image description here

I think maybe my sources.list is wrong some how because I tampered with it seeing if I wasn't getting the correct repositories. I also tried googling for solutions and non seemed to work and I am at a loss for solutions except reinstall the entire OS but that is out of question considering the amount of files and media I have on it.

closed as unclear what you're asking by Jeff Schaller, sebasth, schily, GAD3R, msp9011 Sep 2 '18 at 21:34

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    This looks like Python 2 was replaced with Python 3 such that /usr/bin/python is Python 3 — does that ring any bells? – Stephen Kitt Aug 17 '18 at 6:13
  • A may of done something of that sort. Tried to install Python 3 but accidentally installed python 2 so had to replace it – ScarletHarlot Aug 17 '18 at 7:19
  • 3
    What do you mean by “had to replace it”? Ubuntu needs a working Python 2 installed, and /usr/bin/python has to point at a Python 2 interpreter. – Stephen Kitt Aug 17 '18 at 7:25