2

If I run stat -f . on a bindfs or sshfs filesystem, it shows "Type: fuseblk". This is not right. Unlike ntfs-3g, these filesystems are not implemented using a block device. If I run findmnt, it shows their type as just fuse.

Can it be fixed?

2

I'm guessing this bug is too late to fix. (I.e. it is effectively now also a feature :-).

Currently S_MAGIC_FUSEBLK is defined to represent what I think the kernel internally calls FUSE_SUPER_MAGIC. (Google suggests it might be defined in "fs.h"? But I can't find "fs.h" in coreutils).

stat -f . prints S_MAGIC_FUSEBLK as "Type: fuseblk", which sounds reasonable. The problem is the exact same magic also returned for non-block FUSE filesystems. This is in one of the fields returned by the Linux system call statfs(). I suspect the original author only tested with block-based FUSE filesystems, like ntfs-3g.

I searched the web about this and only found a thread on the original patch. Conveniently, the same thread explained backwards compatibility concerns, as a reason not to update the description of another filesystem type. If this is valid, it sounds like both of the descriptions have now been in place too long, and changing them would be too risky.

https://lists.gnu.org/archive/html/bug-coreutils/2009-12/msg00229.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.