0

My Hiri 1.4.0.4 email client has started crashing upon being called.

I am using Debian Stretch/amd64 in a Lenovo Thinkpad E560 with an i7 6500U CPU @ 2.50GHz and 16GB of RAM. Running xserver-xorg 7.7+19 and fluxbox 1.3.5-2+b2

I have just disabled my radeon card in GRUB with radeon.modeset=0. It is now using the "Intel HD Graphics 520 (rev 07)"

In the process of trying to disable the Radeon, I uninstalled the radeon Xorg drivers the mesa package driver(s) libgl1-mesa-dri.

Now when I call my email app Hiri with hiri.sh, it crashes. It opens the splash screen, but is crashing upon start after it with the errors bellow.

What can I to correct this?

libEGL warning: DRI2: failed to authenticate
libEGL warning: DRI2: failed to open swrast (search paths /usr/lib/x86_64-linux-gnu/dri:${ORIGIN}/dri:/usr/lib/dri)
libEGL warning: DRI2: failed to authenticate
libEGL warning: DRI2: failed to open swrast (search paths /usr/lib/x86_64-linux-gnu/dri:${ORIGIN}/dri:/usr/lib/dri)
./hiri.sh: line 13:  1369 Aborted                 "$SCRIPTDIR/hirimain" $@

Those are my logs about the removed packages from /var/log/apt/history.log

Start-Date: 2018-08-15  13:42:53
Requested-By: xxxxx (1000)
Remove: xserver-xorg-video-all:amd64 (1:7.7+19), xserver-xorg-video-ati:amd64 (1:7.8.0-1+b1), libgl1-mesa-dri:amd64 (13.0.6-1+b2)
Purge: xserver-xorg-video-radeon:amd64 (1:7.8.0-1+b1), libdrm-radeon1:amd64 (2.4.74-1), radeontool:amd64 (1.6.3-1+b1)
End-Date: 2018-08-15  13:42:55

P.S. I also tested Hiri 1.4.0.3. The behaviour is identical.

  • Where did libegl1-mesa-dri come from? Neither packages.debian.org nor Google seems to have heard of it; is that suppoed to be libgl1-mesa-dri? In which case... you want that for Intel graphics, too. libdrm-radeon1 or libdrm-amdgpu1 is the AMD one... – derobert Aug 15 '18 at 21:37
  • @derobert Typo indeed thanks! Actually part of the Hiri ticket points to this post, thanks on helping me correcting it out. Gonna switch to Linux again to confirm this. – Rui F Ribeiro Aug 15 '18 at 21:41
  • @derobert confirmed, nicelly spotted. You cannot deinstall libdrm-radeon1 without deinstalling libgl1-mesa-dri. – Rui F Ribeiro Aug 15 '18 at 21:49
  • @RuiFRibeiro Hmm, appears so. But you shouldn't need to deinstall it anyway. It should just use the Intel DRM when running on an Intel GPU. – derobert Aug 15 '18 at 22:02
  • @derobert I tried it as a stupid alternative before doing the GRUB modeset...the question is a bit about correcting that, more about the hiri problems. – Rui F Ribeiro Aug 15 '18 at 22:03
1

I found out the situation seems to due both to the deleted driver and for the current video card not supporting OpenGL natively - Hiri display an OpenGL? logo when starting.

I tried then to revert the uninstalled packages, including libgl1-mesa-dri, but did not seem much of a change in the error.

apt-get install libgl1-mesa-dri

Had then to install the following package:

apt-get install libegl1-mesa-drivers

After installed it, the apllication already loaded and showed the main screen (the email client main screen).

However now the application while loading, seems to crash either in the first mouse click and/or opening an email, with the following errors:

libEGL warning: DRI2: failed to authenticate
libEGL warning: DRI2: failed to authenticate
[2106:2220:0815/191858.546603:ERROR:gl_implementation.cc(225)] Failed to load libGLESv2.so.2: libGLESv2.so.2: cannot open shared object file: No such file or directory
[2106:2220:0815/191858.885012:ERROR:gl_surface_qt.cpp(667)] Requested OpenGL implementation is not supported. Implementation: 0
./hiri.sh: line 13:  2105 Segmentation fault      "$SCRIPTDIR/hirimain" $@

Upon googling, I found out those errors can be due to a missing libgles2-mesa library. Strangely it was not present before (e.g. it was not one of the uninstalled packages). I then installed it with:

apt-get install libgles2-mesa

After installing this last library/package, the application allowed me to use it.

Also deinstalling update-glx and glx-diversions, and glx-alternative-mesa got finally rid of the message libEGL warning: DRI2: failed to authenticate.

PS. I am just getting a few last applicational, python errors when closing the app , reported them to Hiri.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.