1

I am using Ubuntu 18.04, and trying to moutn Matlab ISO using the following command:

sudo mount R2018a_glnxa64_dvd1.iso /mnt/cdrom -o loop

But terminal is responding back as:

mount: /mnt/cdrom: failed to setup loop device for R2018a_glnxa64_dvd1.iso.

I am not sure as to what this means and how to take it forward.

  • Could you post output of the command: file R2018a_glnxa64_dvd1.iso – Bob Aug 15 '18 at 8:19
0

Create /mnt/cdrom directory first:

mkdir -p /mnt/cdrom

Afterwards mount the iso-image with absolute image path, for example /home/user/R2018a_glnxa64_dvd1.iso instead of just R2018a_glnxa64_dvd1.iso:

sudo mount -o loop /home/user/R2018a_glnxa64_dvd1.iso /mnt/cdrom

If the directory /mnt/cdrom exists, get more info about your iso-image:

file R2018a_glnxa64_dvd1.iso

and try to mount with explicit filesystem type, for example:

sudo mount -o loop -t iso9660 /home/user/R2018a_glnxa64_dvd1.iso /mnt/cdrom

Additionally read my answer at Askubuntu, possibly your image has a boot sector, then mount it with offset option which should be calculated first.

  • Hi. Thanks for the answer but it is giving me the same error: mount: /mnt/cdrom: failed to setup loop device for R2018a_glnxa64_dvd1.iso. – Sayantan Datta Aug 15 '18 at 8:19
  • @SayantanDatta Could you post output of the command: file R2018a_glnxa64_dvd1.iso – Bob Aug 15 '18 at 8:20
  • R2018a_glnxa64_dvd1.iso: ISO 9660 CD-ROM filesystem data 'MATHWORKS_R2018A' – Sayantan Datta Aug 15 '18 at 8:22
  • @SayantanDatta I have edited my answer. You have to add absolute path to image, for example: /home/user/R2018a_glnxa64_dvd1.iso - not just R2018a_glnxa64_dvd1.iso – Bob Aug 15 '18 at 8:26
  • So, I tried doing that and the error still persists - mount: /mnt/cdrom: failed to setup loop device for R2018a_glnxa64_dvd1.iso. – Sayantan Datta Aug 15 '18 at 8:29
0

When I had this problem, I were trying to mount the iso image from a sshfs-mounted directory. After copying the iso image to the local filesystem, it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.