2

I've been trying to get my Asus PCE-AC56 to work with Linux Mint 18.3, which the wireless card has a Broadcom BCM4352 chip on it. I was able to at times, but it would run terrible when playing a game and give me terrible network speed, so I kept trying to find a solution to my speed issue, only for it to be to little to no avail.

I was able to actually get a really good speed out of the card with this (15Mb/s, usual internet speed)! But after I restart, just to be sure that it would work after a simple restart, it stopped working.

I tried to diagnose what was causing the card from not loading, hardware-wise, reported by ndiswrapper -l:

  • tried reinstalling bcmwl-kernel-source via Synaptic Package Manager;

  • removing blacklist bcm43xx, blacklist b43, blacklist b43legacy and blacklist ssb from etc/modprobe.d/blacklist.conf;

  • checking the syslog from /etc/log/syslog but was too much to look through;

  • reinstalling ndiswrapper, ndisgtk, and the driver for the card, which was bcmwl6.inf;

    • the wireless card would've also worked with bcmwdi.inf, regardless of which, as I tested, from my Windows 10 drive, before I restarted

All leading me here back to the same spot, with 'Wireless' in Network Manager nowhere to be found and unable to use my wireless network card.

What am I doing wrong (or did I do wrong) and how can I fix what I could've possibly broke?

EDIT: just in case, both iwconfig and ip addr never printed out a wlan0 nor a bcmwl6 (the second one which ndiswrapper -l outputs)

2

Solution:

Worked after installing broadcom-sta-dkms, then purging it, installing bcmwl-kernel-source, then purging it.
The last few things I did was sudo apt purge ndis*, which removed any ndis-related packages, then reinstalled bcmwl-kernel-source via Driver Manager (which got the WiFi working again, but I would rather use a Windows driver), reverting it back to not use any driver, then reinstall ndisgtk (and required dependencies) as mentioned here.

Finally, installing bcmwl6.inf via the NDISwrapper user interface and reconnecting to my router!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.