I'm using the original EeePC with screen resolution of 800x480. Some screens and dialogs do not fit into that resolution, so I have to use Alt-Drag to move windows around to reveal the bottom part of the window, but this doesn't work for a particular application I'm going to use since it's basically a fullscreen DirectX app running via wine, so some buttons are just cut off by the edge of the screen.

Is there a way to make Xorg desktop to render at higher resolution (1024px wide or so) and then transparently scaled down to the display's native resolution, so the applications think the resolution is bigger? I do not care much about output getting blurred or text getting too small.

Alternatively, is there a way to switch the video adapter to the resolution above physical resolution of the LCD screen and have the screen/video adapter itself to handle scaling (as used to be possible with CRT monitors)?

I'm using Lubuntu 12.04 so I guess have Compiz installed. There is Scale plugin in Compiz, but I don't think it does what I need.

  • 1
    KDE has a way of zooming out... that does something like what you're describing. Though generally you don't do much more than select windows at that level. But I'd say it's possible. Aug 24 '12 at 3:11

In short, you want something like

xrandr --output LVDS --scale 1.28x1.28

(replacing LVDS with the desired output name, as seen in the output of running xrandr by itself).

Give it a try. Some sites said that this doesn't work on some systems that are using KMS (kernel mode setting); if so, that's a bug that's hopefully fixed. See these links for some more info on using xrandr to scale a screen like this:

  • Awesome, I'll try that and report back
    – Sergey
    Aug 24 '12 at 4:36
  • 3
    Setting the screen size worked fine, however, mouse cursor is limited to the previous screen size - I can not move the cursor outside of the invisible 800x480 rectangle. Do you know what might be causing it? If I won't find a solution I guess I'll ask a separate answer.
    – Sergey
    Aug 25 '12 at 10:08
  • Sounds like a known bug: see e.g. bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/883319 and google.com/search?q=xrandr+scale+mouse+limited. There may be a solution in one of those, I haven't looked.
    – Jim Paris
    Aug 26 '12 at 8:27
  • 1
    According to bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/883319/…, the mouse-limiting bug has been fixed in Ubuntu 12.10 although it is now also necessary to specify --panning parameter in the command.
    – Sergey
    Feb 12 '13 at 8:12
  • nice, but doesnt work with my Nvidia. had to use intern intel graphics instead (via nvidia-settings)
    – phil294
    Feb 20 '18 at 2:37

Go here and download "newrez"


I'm the author. It overcomes the trapped mouse problem.

  • 5
    Would you mind adding some more details about newrez? Just to make this answer more canonical than just a link.
    – slm
    Feb 12 '13 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.