0

After following the NixOS' Installation Guide, I'm failing to create a bootable Installation ISO. I created an issue for this on NixOS/nixpkgs. But I wanted to see if there was any knowledge here. Took a look around including this question, and don't see a clear answer beyond what's already in the documentation.

i) Basically, when I try to write a bootable ISO to my USB stick, I can't make it boot. From the boot menu, I run the USB stick, and am immediately exited out of the boot process without any error message. I'm simply immediately placed back in the boot loader.

sudo dd if=~/Downloads/nixos-graphical-18.03.132847.aec217852f2-x86_64-linux.iso of=/dev/sda

sudo dd bs=1024 status=progress if=~/Downloads/nixos-graphical-18.03.132847.aec217852f2-x86_64-linux.iso of=/dev/sda

I also tried ii) reformatting the USB stick with fdisk (bootable, 1 partition, VFAT). And iii) calling sync after the dd write. No dice.

The simple dd copy command works on Ubuntu ISOs. Is there anything else I have to do for NixOS' ISO?

  • 3
    Are you sure /dev/sda is your USB stick? That's usually the first block device in the system, which tends to be the installed SSD/HDD. – Mioriin Aug 12 '18 at 4:55
  • Aside from that, they might just not provide bootable hybrid ISOs supporting UEFI. If you're trying to install Nix anyways, maybe trying with a BIOS-based virtual machine would be better; if that works (and you need to run it on a UEFI-based host), try UEFI-based vm; if that works, try disabling SecureBoot on your host and boot off (external USB) DVD; if that works, you basically got only two choke points to explore. You might also want to read this: rodsbooks.com/efi-bootloaders/principles.html – Michael Shigorin Aug 13 '18 at 12:49
  • 2
    @MichaelShigorin Bingo! I had to turn off "Secure Boot", as the NixOS installer doesn't sign it's ISOs. There's a brief blurb about it in its UEFI_boot section. So I missed that. Much obliged! – Nutritioustim Aug 14 '18 at 4:28
  • 2
    @Nutritioustim Might be a good idea if you put that as an answer and marked it as accepted, so that others in the same situation can benefit from it. :) – Mioriin Aug 14 '18 at 14:49
  • 1
    Glad this helped; I've reposted as an answer for future reference, agreed. – Michael Shigorin Aug 15 '18 at 12:04
2

They might just not provide bootable hybrid ISOs supporting UEFI. If you're trying to install Nix anyways, maybe trying with a BIOS-based virtual machine would be better; if that works (and you need to run it on a UEFI-based host), try UEFI-based vm; if that works, try disabling SecureBoot on your host and boot off (external USB) DVD; if that works, you basically got only two choke points to explore.

You might also want to read this excellent UEFI introduction by Rod Smith (helped me a lot to implement UEFI support in ALT Linux).

  • 1
    This used to work at some point - I don't expect anyone would remove the hybrid ISO property since, but there may be some bugs... – Vladimír Čunát Aug 17 '18 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.